[mythtv-users] DVD ISO playback problems: Invalid IFO

Richard Shaw hobbes1069 at gmail.com
Thu Jan 10 03:35:15 UTC 2008

Tom Greer wrote:
> I had similar problems trying to watch the Planet Earth DVD set that I 
> received for Christmas.  Nothing of the Linux-based apps that I have 
> used in the past could play it.
> Finally, I used DVD Decrypter under wine (using easy how-to that I 
> googled) to copy the five DVDs to hard drive.
> Now it plays beautifully.
> If I had not found a way to play it, I would have returned it and 
> purchased something else that did not contain DRM-crap.
> When will the content owners (in this case the BBC) realize that their 
> DRM efforts are preventing customers from using their products and 
> potentially losing sales.
> By the way, I have no desire or intent to share these copied files 
> with anyone else.  I respect rights of the copyright holders.  I 
> simply want to use the content I have purchased (or in this case 
> received as a gift).  Please don't call me a pirate or insinuate that 
> I have committed some crime. 
> Tom
> On Jan 9, 2008 3:55 AM, Martin Ritchie <ritchiem at apache.org 
> <mailto:ritchiem at apache.org>> wrote:
>     Hi, like others on this list I am seeing the following problem in all
>     the apps I've tried:
>     mplayer,xine,ogle,mythvideo,vlc
>     libdvdread: Invalid IFO for title 2 (VTS_02_0.IFO).
>     Now from what I've found out it seems to be that the libdvdread is
>     getting up set that it cannot determine the Region setting for the
>     'DVD Drive' as this is an iso file there is no drive to query.
>     Has anyone else had this issue and worked past it? The interesting
>     thing to note is that when I started using mythtv I managed to make an
>     ISO copy of a couple of my dvds then forgot what tool I used. Those
>     disks work 100% ok. Having forgotten the tool I used I've started
>     using k3b as it makes iso copies of the DVD and all of those so far
>     only play to the title page. The main features all result in an
>     Invalid IFO error.
>     For reference I'm using the Mythdora 4.0 build as my custom myth box
>     went up in flames and I didn't want to spend an age getting the tv
>     card working again.
>     --
>     Martin Ritchie
>     _______________________________________________
>     mythtv-users mailing list
>     mythtv-users at mythtv.org <mailto:mythtv-users at mythtv.org>
>     http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> ------------------------------------------------------------------------
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Man, I'm really taking the long way around... I'm running Nero Recode & 
AnyDVD combo under XP under VirtualBox. I rip out the menus, extra sound 
tracks and subtitles and then it compresses it to fit on a single layer 
disk. I like that so I know the result will not be bigger than 4.7GB. 
The wife loves it because she can switch between the kids movies easily 
without having to mess with disks. Also, because AnyDVD removes all the 
copy protection and bad sectors the internal player seems to work fine.

I use Xine for real DVD's since I have had the internal player choke on 


More information about the mythtv-users mailing list