[mythtv-users] Help Tracking down a memory leak issue with MythTV SVN

Mitch Gore mitchell.gore at gmail.com
Sun Jan 6 05:42:39 UTC 2008

On Jan 4, 2008 6:24 PM, Alex Halovanic <halovanic at gmail.com> wrote:

> The only thing I've determined is that it's not mythweather related.  That
> would be too easy, wouldn't it?  I'm gonna have a look through some
> detailed
> frontend logs this weekend and maybe try to run the whole thing through
> valgrind or something.  Perhaps the mythmediamonitor is leaking? That's
> running continuously while the frontend is idle.
> Alex
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

Is Alex and I the only ones noticing a memory leak in the latest SVN with
the frontend?  I took a quick poll of my memory usage while watching live
TV.  I have 1Gig of Memory and 2.5 GB of SWAP.  The first column is RAM, the
second is SWAP, and the third is the time.
R     S     T
621 641 10:35
637 641 10:41
642 641 10:48
653 641 10:55
660 640 11:02
683 625 11:15
686 625 11:23
691 622 11:30

As you can see Ram goes up a few MB every poll.  If i leave mythfrontend
running all the time i come to watch TV and my swap and ram is completely

Do any devs have a comment on this?  I find it hard to believe that no one
else is seeing this.  If that is the case we need to figure out what is
going on.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080105/62505b2a/attachment.htm 

More information about the mythtv-users mailing list