[mythtv-users] mythfrontend uses 99% of cpu, unusable (SVN 15267, Gentoo)

R. G. Newbury newbury at mandamus.org
Thu Jan 3 10:34:03 UTC 2008

Justin wrote:

> --------------------------------------------------
> From: "R. G. Newbury" <newbury at mandamus.org>
> Sent: Wednesday, January 02, 2008 10:18 AM
> To: "Discussion about mythtv" <mythtv-users at mythtv.org>
> Subject: Re: [mythtv-users] mythfrontend uses 99% of cpu, unusable (SVN 
> 15267, Gentoo)
>> Justin wrote:
>>> Hi,
>>> I'm having a problem where when I run mythfrontend on my laptop it uses 
>>> around 99% of the cpu, runs so slow it's unusable. The computer is mostly 
>>> to slow to be usable also at the time. I have to kill it over SSH to 
>>> return things to normal.
>>> I'm running SVN revision 15267 on Gentoo Linux 2006.1.
>>> I recently did an update of most of the packages installed so that maybe 
>>> what messed it up. I did recompile mythtv to see if it would help but it 
>>> didn't.
>>> I also tried running it with -v all and -v most and it appears it's doing 
>>> everything just fine except for using most of the cpu and making 
>>> everything unusable.
>>> It doesn't appear to be hanging. I also tried different themepainters 
>>> via -O.
>>> Anyone have any idea what could be the problem or how I might figure it 
>>> out?
>>> Justin
>> What is the video chipset? and the processor.
>> You do not say whether this box did better previously. If so, you
>> probably have missed setting the ./configure switches correctly.
>> More basically, your video driver may not be set up correctly. A via
>> video chipset without openchrome is ssslllloooowww.
>> Need more information...
 > Yes it was working correctly before.
 > The processer is a Intel Pentium 4 M 3.06 Ghz and the video card is a 
 > Radeon IGP 330M/344M/340M (As listed in lspci).
 > I recently have upgraded a bunch of packages including the kernal, 
beryl to
 > compiz. I also installed things like pulseaudio.
 > It worked just fine after the kernel upgrade and install of compiz. It
 > wasn't until around the install of pulseaudio that it stopped worked. 
I just
 > tried removing pulseaudio as my default alsa default but it didn't help.
 > Justin

Please don't top-post.

I think you have pointed to your problem. Pulseaudio is definitely not 
yet ready for prime time. It was installed by default on my Fedora 8 
setup and I had to remove it as I could not get audio to work.

And obviously, the box is capable of doing what you want.

I suggest you try an 'apt-get remove pulse*' or whatever. Otherwise, if 
it wasn't your laptop, but a dedicated system, I would suggest a mythtv 
database backup and re-install. But I strongly suspect that your laptop 
has a large number of other programs on it.

No easy answers to this. as ISTR that removing pulse was a pain, 
although I cannot remember the details of what I did (and it likely 
would be of no help to you anyway due to the different distro).


       Tux says: "Be regular. Eat cron flakes."

More information about the mythtv-users mailing list