[mythtv-users] Missing /dev/lcd0 with Silverstone LC16M

Anthony Giggins seven at seven.dorksville.net
Mon Feb 11 12:08:22 UTC 2008

I've been running myth for about 1 year now running on Mythdora 4.0, So I
finally got the money together to get a nice HTPC case the (Silverstone
LC16M) after carefully check compatibility and reading the wiki but I've run
into a few problems....

I've tested in windows and all is working as expected so there doesn't seem
to be an hardware issues.

1. I'm missing /dev/lcd0 for starters so LCDproc is haing issues.
imon: ERROR opening /dev/lcd0 (No such file or directory).
imon: Did you load the iMON VFD kernel module?
imon: More info in lcdproc/docs/README.imon
Driver [imon] init failed, return code < 0
Could not load driver imon
There is no output driver
Critical error while initializing, abort.

I've checked that lirc_imon module is loaded and I've tried reloading it

lsmod | grep lirc
lirc_imon 20612 0
lirc_dev 18980 1 lirc_imon

2. The imon pad remote appears to be working most of the time except the pad
is still working as mouse input which doesn't work in mythfrontend, I'm not
overly worried about that atm as I've heard mythui should be updated in .21
to allow for mouse and touch screen support, will this be true?

I also found a few errors in my messages log which may be related.... anyone
got any ideas?

Feb 10 17:56:18 myth lircd-0.8.2-CVS[2642]: accepted new client on
Feb 10 17:56:18 myth lircd-0.8.2-CVS[2642]: could not get file information
for /dev/lirc
Feb 10 17:56:18 myth lircd-0.8.2-CVS[2642]: default_init(): No such file or
Feb 10 17:56:18 myth lircd-0.8.2-CVS[2642]: caught signal

3. The hotkeys and volume knob isn't working either but I haven't spent much
time on this as I doubt these will be used often.

Other then the problems above the case is perfect, also the card reader is
working as expected.

I found http://www.mythtv.org/wiki/index.php/SilverstoneTek_LC16M and
http://g-ding.tv/?q=node/1719 but I'm still not getting any joy.

any help/ideas would be great. my main problem right now is the missing
/dev/lcd0 some loggs below

lirc_dev: IR Remote Control driver registered, at major 61
lirc_imon: no version for "lirc_unregister_plugin" found: kernel tainted.
/root/lirc-0.8.2pre2/drivers/lirc_imon/lirc_imon.c: Driver for Soundgraph
iMON MultiMedian IR/VFD w/imon pad2keys patch, v0.3p2k
/root/lirc-0.8.2pre2/drivers/lirc_imon/lirc_imon.c: Venky Raju
usbcore: registered new interface driver lirc_imon



More information about the mythtv-users mailing list