[mythtv-users] Shows not recording - how can I delete DB entries manually?

georgemason george at porthall.net
Tue Feb 5 19:13:20 UTC 2008

Michael T. Dean wrote:
> OK.  That confirms that it's /not/ what I thought.  (Though it seems 
> that what I thought it might be has not been handled.  I'll have to 
> patch that before 0.21.)
> So, when you delete the file, does it pop up a dialog saying, "ERROR: 
> Recorded file does not exist. Are you sure you want to delete: 
> <title>"?  If so, then after you say, "Yes, delete it," it comes back, 
> right?
> Thanks.
> Mike
Not quite, no. What *was* happening was that when I tried to view the
recordings I got that error, but when I deleted them from the UI they
deleted, only to reappear after a restart. Having said this I just tried to
delete them again and it seems to have worked, the entries were deleted from
the list of recordings (without any error being displayed, although it took
up to 10 secs per entry). This means that the behaviour is different than
before, or I have done something differently (although I can't see what). 

I guess I will have to wait and see whether more of these orphaned
recordings are created to see whether the problem persists.

I had tried to create a shell script to ffmpeg the recordings into Flash
files which could then be viewed via Mythweb, running as a user job, not
sure whether this could have caused the orphaned files. I have disabled the
job to see if it makes a difference. Unfortunately I was cobbling it
together from web sources so could have easily made a mistake somewhere.

Will wait and see what happens. Thanks Mike and Steve for your valuable

View this message in context: http://www.nabble.com/Shows-not-recording---how-can-I-delete-DB-entries-manually--tp15258267s15552p15297422.html
Sent from the mythtv-users mailing list archive at Nabble.com.

More information about the mythtv-users mailing list