[mythtv-users] /dev/raw1394 permissions issues

Kevin Kuphal kkuphal at gmail.com
Mon Dec 29 07:23:33 UTC 2008

On Mon, Dec 29, 2008 at 1:16 AM, Gabe Rubin <gaberubin at gmail.com> wrote:

> I upgraded to fedora 10 from version 7, and I think I have solved all
> the little issues that crop up during these upgrades except for one
> issue.
> After a reboot, my mythtv user does not have permission to
> /dev/raw1394 until I do the following: chmod 666 /dev/raw1394.
> I tried following the instructions here:
> <http://www.mythtv.org/wiki/index.php/FireWire#Method_2:_modify_udev_rules
> >,
> but this rule does not affect the permissions post-reboot (I don't
> know much about udev, so maybe the rule isn't even doing anything).
> I can't figure out how to determine the /dev/raw1394 group membership
> to add mythtv to that group as mentioned in the other method. When I
> do an "ls -la /dev/raw*", it shows this "crw-rw-rw- 1 root root 171, 0
> 2007-02-11 13:36 /dev/raw1394" (after changing the permissions).  Does
> that mean it is part of the root group.  If so, isn't that a bad idea
> to make the mythtv user part of the root group?

Why not just add the "chmod 666 /dev/raw1394" to your rc.local (or
equivalent) script so that it is executed on boot?  Or even add it to the
beginning of your mythbackend init script so it is run prior to mythbackend

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20081229/e948ac3d/attachment.htm 

More information about the mythtv-users mailing list