[mythtv-users] Video stutters with Internal DVD Player

Chris Purves chris at northfolk.ca
Sun Dec 14 16:35:43 UTC 2008

On Saturday 13 December 2008 10:17:07 Brian Phillips wrote:
> Chris Purves wrote:
> > Hello,
> >
> > I am having problems with DVD playback.  The video stutters slightly
> > every few seconds.  I have tried various decoder settings:  ffmpeg,
> > libmpeg2, XvMC, all to no avail.  If I set mplayer as the DVD player,
> > the playback is smooth (mplayer is using libmpeg2 for decoding
> > according to the mythfrontend log) so it does not appear to be a
> > hardware issue.
> >
> > There are no entries in mythfrontend.log when the stutter happens.
> >
> > I am running mythtv 0.21 on mythbuntu.
> > Nvidia GeForce 7300 GT
> >
> > Thanks.
> Have you checked top to see if it's a CPU, RAM, or IO (disk access) issue?
> The wa% is very useful sometimes as it can show you there is a hang up with
> your DVD drive.

Investigating more into performance of DVD drive:

disk access wa% is between 5-10%, running hdparm shows buffered disk reads that 
seem slow to me, but I have not been able to find benchmarks on the internet 

chris at mythbox:~$ sudo hdparm -Tt /dev/scd0

 Timing cached reads:   632 MB in  2.00 seconds = 315.72 MB/sec
 Timing buffered disk reads:   10 MB in  3.55 seconds =   2.82 MB/sec

Chris Purves

"Whence come I and whither go I? That is the great unfathomable question, the 
same for every one of us. Science has no answer to it." - Max Planck

More information about the mythtv-users mailing list