[mythtv-users] Myth won't play DVDs, video is shaky

Andrew mythtv at villeneuves.com
Thu Dec 11 21:58:30 UTC 2008

I just changed the playback profile to Normal and the shakiness problem
seems to be totally gone. Woot J Thanks Steve! 


I'm new to MythTV, so I have not familiarized myself with all of the
settings yet. I'm not sure why it defaulted to CPU+. My system can handle
Normal without a problem.  


I've still got a small black bar at the bottom of the screen (neglected to
mention that in my first email). I'm hoping to get rid of it. It shows up at
the bottom, not on any other side of the screen. 


I'd prefer to try to get the internal mythtv player to work before I try to
use an external one like mplayer per your suggestion.




From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Steve Peters -
Priority Electronics
Sent: Thursday, December 11, 2008 1:25 PM
To: 'Discussion about mythtv'
Subject: Re: [mythtv-users] Myth won't play DVDs, video is shaky



My first problem is that Myth won't play DVDs. If I go to Optical Disks >
Play DVD, the screen flashes to black and returns to the Optical Disks menu.
When I built my system a few weeks ago, one of the first things I did was
install myth and then mythplugins. I did not receive my DVD drive from
Pioneer until just a few days ago, so I had not installed libdvdread3. I
have now, and my drive will play encrypted discs in the default Ubuntu
player, but Myth still won't. Do I need to reinstall mythplugins (and if so,
how) or is there something else I should do to troubleshoot this?


Second problem is that TV through Myth is shaky. I am using the Hauppauge
PVR-150 tuner - my Comcast cable is hooked up to it. When I go to watch TV,
there's this sort of flickering effect on screen, which I don't see if the
cable is plugged directly into the TV. This flickering is especially
noticeable with graphics or when I use the controls to preview what is on
other channels. It's not distorted enough that it makes programming
unwatchable, but is pretty annoying. The Myth menus themselves do not
exhibit this problem  - i.e. if I'm in Manage Recordings, or the full
onscreen Program Guide, or Setup, there isn't flickering. It's only when I'm
actually watching TV. 


I've mystified as to why this is occurring and how I can fix it. Ideas?






Andrew, I've run into the same two exact problems you are having.

Problem 1: go into Utilities, then setup, then TV Settings, then playback.
Page 3 of 9 has the playback profiles. Change it to something like Slim or
Normal or whatnot and test out TV playback. One of those should make your
video work just fine. If not, you can even fine tune those to get it to

Problem 2: I still can't get myth to play DVD's using the internal player,
so i changed the settings so that mplayer plays the dvd's. To do that on
your system, do this: go into Utilities, then setup, then Video Settings,
then Player Settings. Change DVD Player Command to: "mplayer dvd://1
-dvd-device /dev/dvd -zoom -quiet -vo xv %s" without the quotes. Press
Finish, then try your dvd out and see if that works. Wored for me. You may
have to configure your remote to work with mplayer. the OSD is not as nice
as myth's, but at least you can watch dvd's now.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20081211/16791c6f/attachment.htm 

More information about the mythtv-users mailing list