[mythtv-users] Database update schema error with trunk utf8

myShade myshade at bredband.net
Sun Dec 7 20:13:51 UTC 2008


I belive i had something similar, going to utf8 from iso???? something.
I ran mysqldump > mythdump.txt and then ran iconv conversion on the
dump. Then imported the converted database.

Something like-
iconv -f iso-8859-1 -t utf-8 mythdump.txt -o mythtv_utf8.txt

Just keep the dump until your sure you got it right.

Br Fredrik

On Sun, 2008-12-07 at 11:07 -0800, freedenizen wrote:
> I'm getting the following error when trying to upgrade from 21-fixes
> to trunk.  Looks like the problem is with converting to utf8.  I'm
> running mysql 5.0.60 but I am upgrading to 5.0.70-r1 incase that
> resolves the issue.  Has anyone else seen this?  I've tried searching
> the lists on dev and commit, I know there has been some work on utf8
> conversion but I couldn't find anything related to this error.
> 2008-12-07 10:54:43.948 Newest Schema Version : 1226
> 2008-12-07 10:54:43.951 Upgrading to schema version 1217
> 2008-12-07 10:54:49.505 DB Error (Performing database upgrade):
> Query was: ALTER TABLE oldprogram  DEFAULT CHARACTER SET default,  MODIFY oldtit
> le varchar(128) CHARACTER SET utf8 COLLATE utf8_bin NOT NULL default '';
> Error was: Driver error was [2/1062]:
> QMYSQL: Unable to execute query
> Database error was:
> Duplicate entry 'Cl' for key 1
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list