[mythtv-users] Mytharchive errors

Harry Devine lifter89 at comcast.net
Wed Dec 3 02:19:05 UTC 2008

Nick Rout wrote:
> On Wed, Dec 3, 2008 at 2:57 PM, Rod Smith <mythtv at rodsbooks.com> wrote:
>> On Tuesday 02 December 2008 08:37:15 pm Harry Devine wrote:
>>> Nick Rout wrote:
>>>> On Wed, Dec 3, 2008 at 1:00 PM, Harry Devine <lifter89 at comcast.net> wrote:
>>>>> 2008-12-01 19:53:16 ERROR: Failed while running ffmpeg to re-encode
>>>>> video. Command was ffmpeg -y -threads 2 -f s16le -ar 48000 -ac 2 -i
>>>>> /tmp/work/1/audout -f rawvideo -pix_fmt yuv420p -s 480x480 -aspect
>>>>> 1.33333 -r 29.97 -i /tmp/work/1/vidout -aspect 1.33333 -r 29.97 -croptop
>>>>> 0 -cropright 0 -cropbottom 0 -cropleft 0 -s 720x480 -b 4771k -vcodec
>>>>> mpeg2video -qmin 5 -qmax 31 -qdiff 31 -ab 192k -ar 48000 -acodec ac3 -f
>>>>> dvd "/tmp/work/1/newfile2.mpg"
>>>> Try running that command by hand as the same user that runs
>>>> mytharchive and see if there is a more informative error message.
>>> I just tried that and got:
>>> Unknown input or output format: s161e
>>> What is the -f option supposed to be?  And why would Myth be putting in
>>> s161e if its not valid?
>> My best guess is that your version of ffmpeg doesn't support s161e, but the
>> MythArchive script expects it to have that support. What Linux distribution
>> are you using, and from where did you install MythTV and ffmpeg? You might be
>> able to fix things by removing your current ffmpeg and re-installing it from
>> another source. It's also conceivable that you could get it working by
>> installing a support package of some sort, but I don't know what package to
>> suggest, offhand. (My knowledge of the tangled Web of audio and video codecs,
>> and the packages that support them, is limited at best.)
> much the same answer as mine. If this is myth/u buntu then enable the
> medibuntu repos and apt-get install ffmpeg and libavcodec.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
I followed the instructions here 
(https://help.ubuntu.com/community/Medibuntu) to enable the repo, and 
when I tried to install ffmpeg and libavcodec, I get:

hdevine at hdevine-desktop:/$ sudo apt-get install ffmpeg libavcodec
Reading package lists... Done
Building dependency tree
Reading state information... Done
ffmpeg is already the newest version.
ffmpeg set to manually installed.
E: Couldn't find package libavcodec

It appears that maybe the latest ffmpeg breaks mytharchive?  Maybe?  
Just a little? ;-)


More information about the mythtv-users mailing list