[mythtv-users] Mythplugins trunk compile errors after upgrade from Fedora 9 to 10

R. G. Newbury newbury at mandamus.org
Tue Dec 2 21:34:10 UTC 2008


OJ wrote:
> 2008/12/2 OJ <olejl77 at gmail.com>:
>> 2008/12/2 Brad DerManouelian <myth at dermanouelian.com>:
>>> On Dec 1, 2008, at 9:45 PM, OJ wrote:
>>>
>>>> Yes I did a make distclean. I even tried to delete the mythtv (top
>>>> directory) directory and 'svn co' again. Nothing helps... On the other
>>>> hand, it looks like there is a lot of Qt3 -> Qt4 porting activity
>>>> going on in the plugins. Maybe that could cause the problems?
>>> Sorry, I can't help out any more other than to check the commits. I
>>> know some stuff recently went in for MythArchive and MythWeather.
>>> Maybe check out a version before those recent changes. The last update
>>> I did was rev 19179 and it compiled without a problem.
>>> _______________________________________________
>>> mythtv-users mailing list
>>> mythtv-users at mythtv.org
>>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>>>
>> I tried rev 19179 as well. Didn't make any difference for me. That
>> means that there is something wrong with my system. I will try and see
>> if I can figure it out.
>>
>> What I find a little strange is that mythtv is compiling / installing
>> correct, but it fails for every plugin (at least the one I have
>> tried).
>>
> 
> When I try to compile the plugins this is what the Makefile generates:
> 
> make
> cd mytharchive/ && make -f Makefile
> make[1]: Entering directory `/usr/local/mythtv/mythplugins/mytharchive'
> cd mytharchive && make -f Makefile
> make[2]: Entering directory
> `/usr/local/mythtv/mythplugins/mytharchive/mytharchive'
> g++ -c -pipe -march=k8 -pthread -I/usr/include/kde/artsc
> -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -Wall
> -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor
> -funit-at-a-time -D__STDC_CONSTANT_MACROS -Wall -W
> -fomit-frame-pointer -O3 -fomit-frame-pointer -D_REENTRANT -DPIC -fPIC
>  -D_GNU_SOURCE -DPREFIX=\"/usr/local\" -DMMX -D_FILE_OFFSET_BITS=64
> -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_PLUGIN -DQT_SHARED
> -DQT_TABLET_SUPPORT -I/usr/lib64/qt-3.3/mkspecs/default -I.
> -I../../../../include -I../../../../include -I../../../../../include
> -I../../../../include/mythtv -I../../../../include/mythtv
> -I../../../../include/mythtv/libmythtv -I/usr/lib64/qt-3.3/include -o
> main.o main.cpp
> 
> Can anyone explain for me why only qt-3.3 stuff is passed to the
> compiler when compiling plugins. Shouldn't something
> /usr/include/Qt.... be there also?
> 

In addition to explicitly adding the includes as in my other post, you 
might check that you are using the qt4 qmake.

Find qmake in /usr/bin, rename it and do

ln -s /usr/bin/qmake-qt4 /usr/bin/qmake


This SHOULD already be done, but...YMMV.

Geoff


-- 
         Please let me know if anything I say offends you.
          I may wish to offend you again in the future.

          Tux says: "Be regular. Eat cron flakes."


More information about the mythtv-users mailing list