[mythtv-users] UPDATE: FireWire Issues on SA 4240HDC

Josh Wisenbaker macshome at afp548.com
Thu Aug 21 13:49:27 UTC 2008

On Aug 19, 2008, at 5:22 PM, Josh Wisenbaker wrote:

> Hi all,
> I've been playing with KnoppMyth R5 on a Core2Duo Mac Mini and the
> FireWire tuner is giving me fits. So far I can change channels, but I
> can never get a channel lock. firewire_tester never reports any
> success with the Generic or SA profiles selected in mythtv-setup.
> mythtv-setup does correctly identify the GUID and model of my SA
> 4240HDC STB.
> I know it isn't an EMI issue on the channels I'm testing. They are
> marked as copy freely and I can in fact record and play them back
> using the AVCapture and VirtualDVHS apps from the FireWire SDK when
> booted into Mac OS X.
> Any tips on how to proceed? I've already burned through the FireWire
> troubleshooting steps I've found in the various wikis.
> Thanks,
> Josh

I've got a bit of an update, but not much good news.

After failing to get KnoppMyth working over FireWire I tried a few  
more distros.

I liked MythDora, but I still have the exact same issue (Once I had  
patched to get the FW working.). I get 100% signal, but only a partial  
I then tried the Mac OS X builds of MythTV backend and frontend, and I  
have the same issues. That was the most frustrating of all as I I  
could quit MythTV, fire up AVCBrowser and stream the video directly to  
VLC and I can capture with ACCVideoCap to a stream file.

I'm rebuilding the KnoppMyth box and will post some logs.


Josh Wisenbaker, ACSA
We're the M in RTFM.

More information about the mythtv-users mailing list