[mythtv-users] commercial detect and seek problems in recent trunk

Michael Rice mikerice1969 at gmail.com
Mon Aug 11 01:26:25 UTC 2008

I was running trunk 16479 (from just before .21 was released) and it
was very stable.
I couldn't wait any longer and recently updated to 17953 and now 18108
to get HDPVR support:

MythTV Version   : 18108M
MythTV Branch    : trunk
Library API      : 0.22.20080806-4
Network Protocol : 40
QT Version       : 4.3.5
Options compiled in:
 linux debug using_oss using_alsa using_arts using_backend using_dbox2
using_dvb using_firewire using_frontend using_hdhomerun using_iptv
using_ivtv using_hdpvr using_joystick_menu using_lirc using_v4l
using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_xvmc_vld
using_bindings_perl using_bindings_python using_opengl
using_ffmpeg_threads using_libavc_5_3 using_live

Unfortunately now I am seeing a problem with seeking and/or commercial
detection.  It appears old recordings are still ok but recordings made
since I've updated have the problem.  When watching a show the
commercial skip kicks in too soon cutting off a portion of the show.
I then turn on notify and continue.  When I get to the actual
commercial and hit the 30 sec forward button it sometimes goes
backwards.  I believe this is happening with my pvr150's and the HDHR
(not sure about the HDPVR as I am not fully expecting that to work at
this point).

It seems like my seek table is broken for new recordings but
rebuilding doesn't seem to help.  I run optimize_mythdb daily and it
reports no problems.

Anyone have any ideas what might be wrong and how to fix it?

More information about the mythtv-users mailing list