[mythtv-users] Audio up/down/mute don't work after upgrade

James Cummings james+mythtv at cummingsfamily.org.uk
Sun Apr 27 18:02:43 UTC 2008


I've just upgraded my myth box to Ubuntu 8.04, and most things seem to
be working ok (not yet tried everything...)  however, something is
wrong with the control of sound.

When I am playing live tv or watching a recording, I cannot
raise/lower the volume or mute.

Now it isn't the remote control or lircd because when I press the keys
the correct thing is displayed on the screen.  I.e. when I press
volume down multiple times, the volume bar comes on the screen and I
can raise and lower it...it just has no actual effect on the volume.
Same with mute, I get 'mute on' temporarily on the screen, but it
doesn't mute it.

So it seems like it is something to do with the audio settings, I've
looked in general -> audio page and tried a few non-alsa settings as
well as the default, /dev/dsp, etc. but nothing seems to work. (one
setting did remove the ability to appear to be changing it at all).

 My mythtv specific audio settings are:

Audio output device: ALSA:default (but tried all of them)
Passthrough: default
Max Audio Channels: Stereo
Upmix: Passive
x Use internal volume controls
Mixer: ALSA:default (but tried /dev/mixer as well)
Mixer Controls: Master (but tried PCM as well)

The output of "alsamixer":

alsamixer: function snd_mixer_load failed: No such file or directory

and "lsmod |grep snd":

~$ lsmod |grep snd
snd_hda_intel         344728  0
snd_pcm_oss            42144  0
snd_mixer_oss          17920  1 snd_pcm_oss
snd_pcm                78596  2 snd_hda_intel,snd_pcm_oss
snd_page_alloc         11400  2 snd_hda_intel,snd_pcm
snd_hwdep              10500  1 snd_hda_intel
snd_seq_dummy           4868  0
snd_seq_oss            35584  0
snd_seq_midi            9376  0
snd_rawmidi            25760  1 snd_seq_midi
snd_seq_midi_event      8320  2 snd_seq_oss,snd_seq_midi
snd_seq                54224  6
snd_timer              24836  2 snd_pcm,snd_seq
snd_seq_device          9612  5
snd                    56996  11
soundcore               8800  1 snd

And "$ lspci |grep Audio" is:

00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)

and output of  "$ aplay -l" is:
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC861 Analog [ALC861 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Just in case any of that helps.

Any suggestions appreciated!


More information about the mythtv-users mailing list