[mythtv-users] Help troubleshooting why remote frontends not able to connect after upgrade

Paul D. Cnudde cnuddep at rogers.com
Sat Apr 26 20:03:05 UTC 2008

Michael T. Dean wrote:
> On 04/26/2008 01:43 PM, Paul D. Cnudde wrote:
>> Greetings,
>> I recently upgraded my mythboxen to 0.21 using the debian packages from 
>> debian-multimedia .  My setup is 1 BE\FE and 2 remote frontends.  All 
>> was working perfectly before the upgrade.
>> When trying to watch recordings on remote frontends this is what i get 
>> after the upgrade:
>> Could not connect to the master backend server -- is it running?  Is the 
>> IP address set for it in the setup program correct?
>> The frontend on the server runs without issue.
>> I stopped the backend , ran mythtv-setup and re-entered the IP address 
>> ( of my server as well creating a PIN, then restarted the 
>> backend.
>> On the remote machine I removed all mysql.txt and config.xml files and 
>> launched mythfrontend. The frontend setup screen is presented, after I 
>> selected the Language, I select the Backend server which is displayed, 
>> get prompted for the PIN, save the backend setting but still can't 
>> connect. I Check the config.xml and mysql.txt file and the right IP is 
>> there -
> Those are the IP address for the MySQL database.
>> When I run mythfrontend -v all from a command line I can see quite 
>> clearly that it has no problem logging in to the database and executing 
>> queries. When I select Media Library -> Watch recordings  for some 
>> reason it is trying to connect to a backend server on the local machine.
>> Connecting to backend server: localhost:6543 (try 1 of 5)
>> of course there isn't one and it times out and fails.  I have double 
>> checked the backend settings and the config.xml and mysql.txt files on 
>> both the backend and the frontend, all the IP addresses are consistent - 
>>  I have run queries against the settings table in the 
>> mythconverg db looking for anything with localhost and nothing turns up. 
>> Does anyone know why my remote frontends would persist in trying to 
>> connect to a backend on localhost?
>> Eternal gratitude comes your way for any suggestions
>> thanks
> Sounds like you configured your master backend with:
> IP address
> The IP address of the master backend server. All frontend and non-master 
> backend machines will connect to this server.  If you only have one 
> backend, this should be the same IP address as above.
> set to
> Mike
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
I configured my master backend server with the IP address of the machine 
it runs on,, this worked before.  For the sake of argument I 
set it back to, but still I get no joy. In fact the frontend 
setup program doesn't even detect the Backend sever if I do that, and 
doesn't prompt me for a PIN.  I set it back to

Below is an excerpt from the front end logs:

2008-04-26 15:36:15.638 Using runtime prefix = /usr, libdir = /usr/lib
2008-04-26 15:36:16.274 DPMS is active.
2008-04-26 15:36:16.295 Empty LocalHostName.
2008-04-26 15:36:16.295 Using localhost value of poobah
2008-04-26 15:36:16.297 Testing network connectivity to
2008-04-26 15:36:16.439 New DB connection, total: 1
2008-04-26 15:36:16.464 Connected to database 'mythconverg' at host:

I'm not sure why its even concerned with localhost or LocalHostName. 
As you can see no problem connecting to the db
anyway a bit later on:

2008-04-26 15:36:24.761 Connecting to backend server: localhost:6543 
(try 1 of 5)
2008-04-26 15:36:24.762 Connection timed out.         
            You probably should modify the Master Server
            settings in the setup program and set the   
            proper IP address.
2008-04-26 15:36:27.947 Connecting to backend server: localhost:6543 
(try 1 of 5)
2008-04-26 15:36:27.948 Connection timed out.         
            You probably should modify the Master Server
            settings in the setup program and set the   
            proper IP address.
2008-04-26 15:36:29.551 Deleting UPnP client...

my config.xml looks like this(with the naughty bits removed):


Am I missing something here?  Man, I feel like if I had 2 brains I'd be 
twice as stupid.

Let me know if I can supply any more info. 

Is it possible that this is some kind of networking config issue like 
putting something in /etc/hosts.allow ?

Thanks again

More information about the mythtv-users mailing list