[mythtv-users] firewire trouble on SA 4240HDC

Kirk Haines kirk.haines at gmail.com
Sat Apr 19 21:21:12 UTC 2008

Thanks Robert, that makes a lot of sense for what I am experiencing.
When trying to set all this up, I ran into many citations to FCC
regulations regarding firewire ports and capabilities.  Are they
legally obligated to do anything in this case, and if so what?  Also
what specifically should I ask for and what is the best way to do so?

>What you're describing is the behavior of a firewire box when all the
> channels are 5C encrypted.  Sorry, but if I had to put money on it, I'd say
> you're not going to be able to capture video via firewire with your provider.
> To head off a possible followup question, the box is not the issue, as the
> port behaviors are dictated by the headend, not the box itself.  You can
> try to get your provider to flash your STB with an amended policy, but
> that's usually a lost cause.

On Sat, Apr 19, 2008 at 12:17 AM, Kirk Haines <kirk.haines at gmail.com> wrote:
> I am trying to setup a Scientific Atlanta 4240HDC over a firewire
>  connection.  My cable vendor here in Oklahoma City is Cox
>  Communications.  The 4240 shows up in plugreport, but have only seen
>  failure with firewire_tester.  Despite that I continued with setting
>  up mythtv.  Once I had the backend up and running, I started the
>  frontend to see if by some chance I could get a signal.  Unfortunately
>  all I got was a blank screen with "(L__) Partial Lock" below the
>  channel and program title (on all tested channels: SD networks, HD
>  networks, SD cable, HD cable).  However, it appears to be changing
>  channels correctly on the 4240.  I have tried using P2P as well as
>  broadcast, different connection speeds, different protocols (Generic,
>  4200HD, and 4250HDC still let me change channels), but to no avail.  I
>  receive messages from mythbackend that I have not received any data
>  from the firewire connection in X msec.
>  So now I am stuck with knowing the firewire works (since it changes
>  the channel), and that the firewire doesn't work (since it gives me no
>  video).  I can only speculate that I am having a protocol problem
>  somewhere.
>  I tried to follow the procedures outlined in the webpages below to
>  setup this system.
>  http://www.mythtv.org/wiki/index.php/Installing_MythTV_on_Fedora
>  http://www.mythtv.org/wiki/index.php/FireWire
>  I started with a Fedora 8 LiveCD to install since this machine doesn't
>  have a DVD drive.  The firewall and SELinux are disabled.  Also, no
>  extra video drivers or audio was setup (this machine is only to be a
>  backend once it is up and running).  As bizarre as it sounded, I
>  followed the instructions about blacklisting the newer (kernel
>  2.6.22+) firewire modules.  I am currently running the backend
>  manually as root in an effort to avoid any permission issues at this
>  point.
>  I have been using MythTV for about 3 years with analog cable and have
>  enjoyed it immensely.  I am not looking forward to the prospect of
>  going to some $20/mo. 'service' that Cox provides.  Any assistance
>  would be greatly appreciated.

More information about the mythtv-users mailing list