[mythtv-users] Black screen if preview has not yet played

Bob Cottingham bobnvic at gmail.com
Wed Apr 9 16:10:09 UTC 2008

On 4/8/08, Michael T. Dean <mtdean at thirdcontact.com> wrote:
> On 04/08/2008 10:58 AM, Rich West wrote:
> > I have (really, the family noticed first) noticed an odd phenomenon when
> > playing recordings under 0.21.  It seems that if we are too fast
> > navigating and quickly select the show we wish to watch, it won't play:
> > it will sit at a black screen and eventually return us back to the
> > recordings page.  Now, if we wait for the little preview (we have
> > previews enabled) to start up (only takes a few additional seconds) on
> > the recordings page, we can play the recording with no problem.
> >
> > Unfortunately, we're all a bit fast, so the black screen issue seems to
> > come up a lot...
> >
> > Is this a potential config issue here?  Something that I might not have
> > set or something that needs to be set?
> I/O issues causing mythfrontend to think it has read to the end of the
> file.  If you wait for the preview to start up, it's able to start
> reading from the already cached data, which gives the I/O subsystem time
> to start pulling additional data from the file.  I don't have a
> solution, just a pointer to the area that's almost definitely causing
> the symptom.
> Based on the symptom you're seeing, too, I'm guessing you're using a
> network filesystem of some sort (as you'd probably have to be /really/
> quick to see this with a locally-accessible recording--or you've got a
> really messed up system :).

I see the exact same thing, though I hadn't really tied it in to how
long the preview had played. We just start the video, listen to the
hard drive grind for about five seconds with a black screen until it
returns to the Watch Recordings Screen. It always starts immediately
on the second attempt.  I've been meaning to get some good logs and
submit a ticket, but haven't had time.

On my system, however, this is occurring with recordings that are
local and I don't believe we are being particularly quick to start
recording. I am going to try pausing for a few seconds and ensuring
that the preview video is playing before starting recordings tonight
to see if it occurs.

Bob C

More information about the mythtv-users mailing list