[mythtv-users] Sound stops during recording, Audio buffer overflow

Josh Mastronarde jmastron at gmail.com
Sun Sep 23 04:48:53 UTC 2007

Okay, I think I've done enough debug myself and searching to see if
this has come up and am ready to ask for help here:

On my 0.20.2 setup (both FC6 and F7), at random (typically within 5-20
minutes after starting playback of a recorded show or live TV,
sometimes longer but usually within an hour), the sound stops.  The
only way to get it back is to exit back to the recordings screen (or
the main menu if watching live TV), and start again.  At that point
the sound works again.

This seems similar to what was reported in this thread:


But there wasn't a full resolution there, and I've tried both settings
of the audio buffer options mentioned there.  This is the message in
the frontend log when it occurs (repeated many times):

2007-09-22 01:12:18.662 NVP::AddAudioData():p1: Audio buffer overflow,
audio data lost!

Things I've tried:

- Ensured that the recorded mpg files don't have audio issues; they
seem fine (I can skip back and forth around the failure time after
restarting playback with no issues)

- Checked live TV instead of a recorded file.  Same issue happens.

- Built a fresh Fedora 7 partition, installed 0.20.2 on it.  Same issue.

- Tried "mythtv-trunk" from atrpms on the same F7 partition.  Same issue

What I haven't yet tried:

- Getting new ALSA versions (I'm using whatever's part of the kernel)

- Installing a cheap PCI or USB audio card and disabling the onboard AC97.

Here's the lspci info from the onboard audio controller:

00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER
(ICH5/ICH5R) AC'97 Audio Controller (rev 02)
        Subsystem: Foxconn International, Inc. Unknown device 0c48
        Flags: bus master, medium devsel, latency 0, IRQ 20
        I/O ports at e500 [size=256]
        I/O ports at e600 [size=64]
        Memory at fa101000 (32-bit, non-prefetchable) [size=512]
        Memory at fa102000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2

Any suggestions?  I'm not sure how to figure out whether this overflow
is occurring within something inside MythTV (in the decoding flow), or
while trying to control the audio controller (either in Myth or in the
driver), or whether it could be a hardware failure.  As far as I can
tell, this started happening with 0.20.2; I don't recall it ever
happening before that, but it's constant now.  Any help is much



More information about the mythtv-users mailing list