[mythtv-users] New to mythtv - unable to watch channels

Dan Wilson dwilson at dslextreme.com
Sat Sep 22 15:02:30 UTC 2007


I am new to mythtv, having just installed it onto a pre-existing fedora 7 system, into which I just put a PVR-500 video capture card.

If I copy /dev/video0 to a file, I can view the resulting captured tv signal via mplayer, although I couldn't use xvideo, I had to specify x11 (I have an ATI Radeon-family card, and apparently ATI's driver doesn't support XV?).

When I try to use mythtv, however, I see two problems, and I suspect they are related.

First, mythtv-setup doesn't appear to do anything when I try to select the "Fetch channels from listings source" button in the "Connect source to input" screen.  However, if I select "Scan for channels", it shows all of the channels I would expect to find, and none that I wouldn't, so possibly it is finding the channels?

When I run mythbackend and mythfrontend, and select "Watch TV", I get a blank screen, which eventually returns to the mythtv menu.  In the mythbackend console, I see the following:
2007-09-22 07:55:50.240 TVRec(1): Changing from None to WatchingLiveTV
2007-09-22 07:55:50.241 TVRec(1): HW Tuner: 1->1
2007-09-22 07:55:50.444 NVR: Won't work with the streaming interface, falling back
VIDIOCGMBUF:: Invalid argument
2007-09-22 07:56:30.448 TVRec(1): Changing from WatchingLiveTV to None
2007-09-22 07:56:30.451 Finished recording Unknown: channel 1098

Mythfrontend log shows:
2007-09-22 07:55:50.238 TV: Attempting to change from None to WatchingLiveTV
2007-09-22 07:55:50.239 Using protocol version 31
2007-09-22 07:56:30.445 TV Error: StartRecorder() -- timed out waiting for recorder to start
2007-09-22 07:56:30.447 TV Error: LiveTV not successfully started
2007-09-22 07:56:30.453 TV: Deleting TV Chain in destructor

I'm sure I just have missed something stupid?  Any help is greatly appreciated!



More information about the mythtv-users mailing list