[mythtv-users] Mythfrontend QUERY_RECORDINGS timeout - hangs frontend

Craig Ghareeb cghareeb at comcast.net
Fri Sep 21 00:18:25 UTC 2007

>> From: Michael Kurtz <myth at friendz.de>
>> Hi....
>> recently I had the same problem too.Here frontend and backend reside on the 
>> same machine. I know this is not an opitimal solution but deleting the entire 
>> database and setting it up again solved this issue.
>> Michael
>I've had the same problem intermittently for close to 6 months.
>I get messages like the following from my frontend:
>2007-09-20 08:06:12.514 MythSocket(9867b08:10): readStringList: Error, timeout.
>2007-09-20 08:06:12.514 Connection to backend server lost
>2007-09-20 08:06:12.520 Connecting to backend server: (try 1 of 5)
>2007-09-20 08:06:12.522 Using protocol version 31
>2007-09-20 08:06:12.526 MythSocket(aed9d7e0:10): writeStringList: Error, invalid string list.
>2007-09-20 08:06:42.526 MythSocket(aed9d7e0:10): readStringList: Error, timeout.
>2007-09-20 08:06:42.526 Reconnection to backend server failed
>I'm running the same myth on frontend/backend (0.20.2-165.fc6 from ATRPMS).
>Usually, just the frontend hangs; occasionally the backend dies as 
>well -- which sucks if it's recording something at the time.....
>I think it only happens when going to the "Watch Recordings" screen 
>with the list of recordings to watch, or when returning to that list
>from watching something.
>Deleting the entire database sounds painful.
>I have over 1700 recordings (records in recorded table).
>I wonder if it's something specific in the database, or
>is it just the sheer size of the database?

I had the same problem after migration of a 0.19 database to 0.20.2.  The fix for me, strangely, was:

1.  Backup the mysql database
2.  Drop mythconverg
3.  Create mythconverg from .../database/mc.sql
4.  Run mythtvsetup
5.  Create a restore.sql and restore the database using the info in http://www.mythtv.org/docs/mythtv-HOWTO-23.html#ss23.7 

I can't figure out how this would've solved the problem (or what the cause really was), but with the 'fix' only being a week old, I haven't been inclined to try to recreate the problem.


More information about the mythtv-users mailing list