[mythtv-users] OT Help: mdadm segfault

Marc drayson at net1plus.com
Thu Sep 20 03:34:09 UTC 2007

From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Steve MacLaren
Sent: Tuesday, September 18, 2007 1:22 AM
To: Discussion about mythtv
Subject: Re: [mythtv-users] OT Help: mdadm segfault



On 9/17/07, Steve MacLaren <scram69 at gmail.com> wrote:


On 9/17/07, John Drescher < drescherjm at gmail.com
<mailto:drescherjm at gmail.com> > wrote:

> Sadly, I got the same "/dev/sd* has no superblock" regardless of which
> I put first in the list.  So all 4 drives failed simultaneously?
You want to put all 4 drives with the correct partition. Are you sure 
it is /dev/sda and not /dev/sda1?

Oops, I guess the right partition is important...

This time mdadm --assemble /dev/.static/dev/md0 /dev/sd*1 resulted in
something like:
"md0 assembled with 4 devices" 
However, I don't get long to savor my success, because the machine reboots
within about 10 seconds of successfully assembling the raid array.  I tried
to assemble again after the reboot, and got the same exact results - I don't
even get enough time to type a mount command. 

I guess this explains the continuous reboot loop I wound up in earlier.
What is it about just assembling an array that would cause a reboot?

Out of desperation, I even booted off the liveCD, used Synaptic to install
mdadm in the liveCD environment, and then attempted to assemble the array
(sudo mdadm --assemble --scan).  Exact same result: "md0 assembled with 4
devices" followed 10 seconds later by a reboot... 


This sounds good but it also sounds too good. Hoping it is correct.

I had an issue with the PSU in my system always causing one drive to lose
power leaving my RAID5 in a degraded state.

Athlon64 with 6 HDD (2 in RAID1, 4 in RAID5) a CD Rom drive and 5 AGP/PCI
devices (1 video card and 5 capture cards(one PVR-500)) all running off a
550watt PSU.

Installed an 800Watter and my issue went away.. 

Yours however sounds very different. While the explanation sounds good I
have never seen it happen myself.. and the fact that in my situation it
didn't do the same thing makes me a sceptic.. thou it might be due to the
fact that I had a modular PSU in the system so that, maybe, only one rail
fell below the limit and only dropped that one drive.


I'm hoping I'm wrong but still.. And MDADM seg faulting is a little weird.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070919/94201cc9/attachment-0001.htm 

More information about the mythtv-users mailing list