[mythtv-users] anomalies encountered updating to/for Schedules Direct

D. Hugh Redelmeier hugh at mimosa.com
Tue Sep 18 18:17:54 UTC 2007

I have a Fedora Core 5 box with a bunch of PVR-150-like tuners that
was running a year old version of MythTV.  I upgraded MythTV so that I
could migrate from Zap2it to Schedules Direct.  Along the way, I
experienced several anomalies.

1) I use ATRPMS as my source of MythTV.  ATRPMS no longer supports
   Fedora Core 5.  I had three choices:

- switch to a different Linux distro and Myth packager
  Rejected: I was comfortable with the current setup and wished to
  perturb it as little as possible.  See also the next point.

- update my box the a more recent Fedora Core that is supported
  Rejected: I use TV-out on my ATI Radeon 9000 family.  The Gatos patches
  for X to allow this have not been updated to apply to recent
  versions of X.  The closed-source X driver no longer supports this
  card, so that isn't an option (the last version to support this card
  has bugs in the TV-out).  So I'm stuck with old X and hence an
  old Linux distro, and hence I might as well stay where I am.
  An argument could be made for a distro with longer-term support
  (Centos or Ubuntu 6.06 LTS).

- build my own MythTV package.  This I did, using ATRPMS source RPM
  and a dubious set of RPM macros to match ATRPMS environment.  So
  far, so good.  This has been discussed on the atrpms-devel mailing

2) It wasn't obvious to me how to delete an individual Video source in
   mythtvsetup.  I've since learned that, in the Video sources screen,
   if you move the cursor to the source that you wish to delete, you
   can type "d" to request to delete it.  Is this documented

3) I left Zap2it as a source and added SchedulesDirect as a new source.  
   I then switched all my Input connections to use Schedules Direct 
   instead of Zap2it.  This seems reasonable: during the transition 
   period, I'd like to be able to go back to Zap2it.

   I ran into a problem that I think is related to this.  After
   apparently working for a couple of weeks, my guide information
   stopped at 8PM last night.  I tried all sorts of variations on
   mythfilldatabase to try to fix it.  Even though Zap2it was not used
   by any input connection, and Schedules Direct was being used, the
   Zap2it failure apparently blocked guide updating (even though the log
   seemed to show Schedules Direct processing).  I edited the Zap2it
   source to actually use Schedules Direct.  Once that was done, the
   guide was correctly populated.

4) In my mucking about with the Video sources, I accidentally switched
   to the Digital lineup for my cable company.  I wish to use the
   analogue lineup because that lets me use the tuner cards without
   a digital cable set top box.

   When I switched back, my guide was still populated with all that
   digital stuff.  How can I get rid of it?
	mythfilldatabase --refresh-all --do-channel-updates
   does not do the trick.

5) whenever I exit mythtvsetup, it complains with messages like this:
	Card 0 (type) is set to start on channel 2, which does not exist.
   and offers to let me go back to fix the problem.  How can I do
   that?  Channel 2 certainly seems like a valid channel to me.

6) mythtvsetup detects and warns if the backend is running (good!).
   The message, on my screen reads:
	WARNING: MythTV has detected that the
	backend is running.

	Changing existing card inputs, deleting
	anything, or scanning for channels may not

   Clearly this message is truncated.  That should be fixed.
   It would be good if the message said that "mythtvsetup"
   detected the problem, not "MythTV".

7) starting up and running mythtvsetup on a remote machine (i.e. X
   server connected via LAN) with a big screen (2560x1600) is very slow.

More information about the mythtv-users mailing list