[mythtv-users] OT Help: mdadm segfault

Steve MacLaren scram69 at gmail.com
Tue Sep 18 05:22:19 UTC 2007

On 9/17/07, Steve MacLaren <scram69 at gmail.com> wrote:
> On 9/17/07, John Drescher <drescherjm at gmail.com> wrote:
> >
> > > Sadly, I got the same "/dev/sd* has no superblock" regardless of which
> > drive
> > > I put first in the list.  So all 4 drives failed simultaneously?
> > >
> > You want to put all 4 drives with the correct partition. Are you sure
> > it is /dev/sda and not /dev/sda1?
> >
> > Oops, I guess the right partition is important...
> This time mdadm --assemble /dev/.static/dev/md0 /dev/sd*1 resulted in
> something like:
> "md0 assembled with 4 devices"
> However, I don't get long to savor my success, because the machine reboots
> within about 10 seconds of successfully assembling the raid array.  I tried
> to assemble again after the reboot, and got the same exact results - I don't
> even get enough time to type a mount command.
> I guess this explains the continuous reboot loop I wound up in earlier.
> What is it about just assembling an array that would cause a reboot?
Out of desperation, I even booted off the liveCD, used Synaptic to install
mdadm in the liveCD environment, and then attempted to assemble the array
(sudo mdadm --assemble --scan).  Exact same result: "md0 assembled with 4
devices" followed 10 seconds later by a reboot...
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070917/c3166b0a/attachment.htm 

More information about the mythtv-users mailing list