[mythtv-users] No SD Update and SD Episode Numbers do notmatchprevious recordings

Cottrell, Eric ecottrell at doble.com
Mon Sep 17 16:12:41 UTC 2007

> -----Original Message-----
> From: mythtv-users-bounces at mythtv.org 
> [mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Michael T. Dean
> Sent: Sunday, September 16, 2007 5:39 PM
> To: Discussion about mythtv
> Subject: Re: [mythtv-users] No SD Update and SD Episode 
> Numbers do notmatchprevious recordings
> On 09/15/2007 10:41 PM, Cottrell, Eric wrote:
> > I am still having a problem with SD Update not running.  Fixing the 
> > Capture Card info did not fix this problem.
> >
> > Looking through the database I noticed a table called housekeeping. 
> > There is an entry called MythFillDB with a date of 
> September 10, 2007. 
> > This is the last date I used Version 0.16.  I searched on 
> MythFillDB 
> > and came across a message from 2004 about MythFillDB.sh not running 
> > due to no MythFillDB entry in the housekeeping table.  I 
> searched and 
> > found no MythFillDB so I assume it got replaced by MythFillDatabase.
> >
> > I noticed there is no MythFillDatabase entry in the housekeeping 
> > table. Does there need to be a MythFillDatabase entry so 
> housekeeping 
> > will run it?
> OK, I'm totally confused about what you did and did not find, 
> so, I hope this is helpful.
> The housekeeper still (even in SVN trunk) uses the tag 
> "MythFillDB" to identify the lastrun date of 
> mythfilldatabase.  There is no "MythFillDatabase" tag.
> However, the "MythFillDB" tag is only used (by Myth) if you 
> enable "Automatically run mythfilldatabase".  If you're using 
> an external "timer" (i.e. cron) to run your MythFillDB.sh 
> script, it won't be updated.


Thanks for replying.

I have "Automatically run mythfilldatabase" checked.  I tried unchecking
and checking again.  I tried using the full path to mythfilldatabase and
the default.  I tried it with the use suggested time both checked and

Running mythfilldatabase from the command line works.  It never runs
from MythTV.  No log entries.  The other two housekeeping tasks are
running as the dates in the housekeeping table are updating.

I am running SuSE 10.2 with the latest MythTV packages (0.20.2) from
Packman mirror.  After install I restored my old database.  I am going
to grab the latest SVN source and compile it myself.  I understand there
are some bugs in the suggested time portion that were fixed.  Maybe it
is causing other problems.

73 Eric

More information about the mythtv-users mailing list