[mythtv-users] X config problem FC7, nvidia - SOLVED

Nowhere nowhere at cox.net
Mon Sep 17 00:42:43 UTC 2007

Ok, seems conventions keep changing... 


had to rename the symlink pointing to the driver from .o to .so

Does anyone know if this would cause a problem in Ubuntu X as well?


-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Nowhere
Sent: Sunday, September 16, 2007 4:32 PM
To: 'Discussion about mythtv'
Subject: [mythtv-users] X config problem FC7, nvidia

Sorry to self reply but here is some more information.

After x doesn’t start, Im at init 3 I suppose (command line). I uninstalled
ALL nvidia drivers and tried installing the older 7184. After installing,
and startx, I get a page full of error message but the interesting part is 

Failed to load module nvidia, module does not exist, 0
No drivers available.

Please help!


From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Nowhere
Sent: Sunday, September 16, 2007 3:28 PM
To: mythtv-users at mythtv.org
Subject: [mythtv-users] Kernel downgrade complete, now xorg problems

Thanks for the location of the 4-65 kernel. I was able to get LIRC installed
and working on the older kernel. Killing me putting up a new kernel for
updates without any packages built for it and deleting the previous version.

Anyway current problem is with nvidia-graphics9755 and F7 4-65. Yum install
does not produce a viable xorg.conf file. Upon restart, the xserver will not
start complaining about cant find screen or cant find device. Pasting in the
Device, Monitor and Screen entries for the nvidia driver etc will not fix
it. I reran system-config-display which creates a generic conf file, I edit
it with higher res and correct monitor, x will start at 1280x1024 24 ok.
Running mythtv-setup or mythfrontend gives me horrible orange black yellow
color rainbow effect on the GANT theme. I can read it but drilling into the
menu system, the escaping out one menu crashes X. 

I notice the Device entry has “nv” as the driver instead of “nvidia.” Im
guessing Im not using the nvidia restricted drivers?  If I change it, X no
workie.  Should I downgrade the nvidia drivers? If so to which version? Is
it a FC7 thingy?

Any other clues?

Soooo close!


mythtv-users mailing list
mythtv-users at mythtv.org

More information about the mythtv-users mailing list