[mythtv-users] Upgrade to F7/0.20.2 broke GANT/mythtvsetup (fonts?)

Allen J. Newton anewton at alturia.fleet.org
Sun Sep 16 21:45:30 UTC 2007

Hi, Roo, you wrote:
> From: Roo <roo.watt at gmail.com>
> Subject: Re: Upgrade to F7/0.20.2 broke GANT/mythtvsetup 	(fonts?)
> To: "Discussion about mythtv" <mythtv-users at mythtv.org>
> On 16/09/2007, Allen J. Newton <anewton at alturia.fleet.org> wrote:
> > I noticed right after the upgrade that running mythfrontend with the GANT
> > theme (which I had always previously used) no longer showed a menu on the
> > first (or subsequent) pages -- only the background image.  Same goes for
> > mythtvsetup.
> Try the qt painter in setup->appearance (or similar), maybe opengl
> isn't setup properly in your xorg.conf?

Hmmm, changing that didn't seem to have any effect that I could see (Qt vs.
openGL).  As far as I can tell, openGL should be set up correctly in my
xorg.conf (attached).  If you can see anything deficient, please point it out.

One update regarding OSD:  I discovered that, under FC5/mythtv-0.20.1 I was
using the abstractOSD theme for the OSD.  I didn't have that theme installed,
therefore was not getting the OSD.  I changed to a theme that was installed by
default (isthmus) and now get an OSD.  I also installed abstract theme and
have the abstractOSD back, too.

I still get no menu under GANT theme, though, although GANT theme is
definitely installed (which is what really prompted this post).


Allen J. Newton  (anewton at alturia.fleet.org)
-------------- next part --------------
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister at builder3)  Wed Jun 13 18:39:30 PDT 2007

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"
    RgbPath         "/usr/X11R6/lib/X11/rgb"
	ModulePath      "/usr/lib/xorg/modules/extensions/nvidia"
	ModulePath      "/usr/lib/xorg/modules/extensions"
	ModulePath      "/usr/lib/xorg/modules"
    FontPath        "unix/:7100"

Section "Module"
    Load    "dbe"
    Load    "extmod"
	Load    "fbdevhw"
    Load    "type1"
    Load    "freetype"
    Load    "glx"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier  "Keyboard0"
    Driver      "kbd"
	#Option	    "XkbModel" "pc105"
	#Option	    "XkbLayout" "us"

Section "Monitor"
    Identifier  "Monitor0"
	VendorName  "ViewSonic"
	ModelName   "ViewSonic VX2000"
    HorizSync   30.0 - 110.0
    VertRefresh 50.0 - 150.0
	ModeLine    "1680x1050_60.00" 147.1 1680 1784 1968 2256 1050 1051 1054 1087 -hsync +vsync
    #Option      "DPMS"

Section "Extensions"
    Option "Composite" "Disable"

Section "Device"
	Identifier  "NVIDIA GeForce 7300GT"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"

Section "Screen"
    Identifier      "Screen0"
	Device          "NVIDIA GeForce 7300GT"
    Monitor         "Monitor0"
    DefaultDepth    24
    Option          "NoLogo" "True"
    Option          "RenderAccel" "True"
    #Option          "Overlay" "True"
    #Option          "AllowDDCCI" "True"
    Option          "UseDisplayDevice" "DFP"
    Option          "UseEvents" "True"
    SubSection      "Display"
        Depth       24
        #Modes       "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
		Modes       "1680x1050_60.00" "1400x1050" "1280x960" "1280x800" "1280x1024" "1152x864" "1152x768" "1024x768" "800x600" "640x480"

More information about the mythtv-users mailing list