[mythtv-users] EIT crawling not working ?

Daniel Kristjansson danielk at cuymedia.net
Sun Sep 16 15:21:57 UTC 2007

On Sun, 2007-09-16 at 17:14 +0400, Dave wrote:
> Is anyone with DVB-S having problems with EIT crawling not updating the 
> EPG ?
> When i leave my box onto idle (i.e it's on the main menu, and there is 
> no pending events to record), i see no EIT crawling and the EPG never 
> updates.
> Although i get (at the very least) the transmitted now/next events with 
> all my channels it never shows up if i go to the EPG or in the 
> database/web page.
> Anyone with non-xmltv data from grabbers seeing this ?
> I have useonairguide=1 for all my channels, and if i go to the 
> respective channel manually, then the data is populated, so i know it's 
> there, it's just not filling it with the crawler.
> Is there somehow i can turn on debugging of the EIT crawler to try and 
> track this down ?

mythbackend -v channel,eit,siparser

Also in mythtv-setup under General on the fourth pane, "EIT Scanner
Options" you can configure when the scan starts and how long it
spends on each transport. Finally if you have the Listings grabber
in your video source set to anything other than "Transmitted guide
only (EIT)" there is a checkbox that must be checked, "Perform EIT
Scan", this is disabled by default as having multiple listings
grabbers per source can mess up scheduling. If you get EIT for some
channels and info from elsewhere for other channels you can use
the useronairguide on a per channel basis to select who populates
that particular channel.

-- Daniel

More information about the mythtv-users mailing list