[mythtv-users] DisplaySize and TV/video/widescreen settings

Michael T. Dean mtdean at thirdcontact.com
Sun Sep 16 12:41:54 UTC 2007

On 09/15/2007 11:52 PM, William Pettersson wrote:
> I've got Myth hooked up to a T2760.  It runs over a VGA cable at
> 1280x768 resolution, but the screen dimensions are 16:9 (60cm x 33.5cm).
> I've set "DisplaySize 325 182" which I think is correct according to
> http://www.mythtv.org/wiki/index.php/Display_Size but I always have
> black bars at the top and bottom of my screen when watching recorded
> shows that I'm pretty sure are 16:9 widescreen.
> Aspect Ratio is set to "off" in the Mythtv settings at this point.
> If I select "4:3" aspect ratio, then everything seems to be fine.  That
> is, 16:9 widescreen recorded shows take up all the screen, and 4:3
> programs only leave black bars on the side.
> So ok, I have it working I guess.  But is this how things are meant to
> be set up?  I'm just confused as to why selecting "4:3" aspect ratio,
> makes 16:9 shows displayer properly on my 16:9 tv?  What have I done
> wrong/strangely?

Though you described the right configuration, the settings aren't being
applied.  Note that with NVIDIA (and many other) drivers, if the
monitor/TV reports EDID info, it's often not used.

More likely, though, you'll find a section in mythfrontend Appearance
Settings on the page "Screen settings" that's labeled "Monitor Aspect
Ratio".  This appears only if you're using Xinerama or (due to a bug) if
you're using a very new version of X server.  If that setting is there
and you have two (or more) displays, just set it to 16:9.  If you're
only using one monitor and the setting is there, try setting it--though
it shouldn't be there and a patch (to be applied "soon") will fix the issue.


More information about the mythtv-users mailing list