[mythtv-users] Trouble building from trunk source (14490)

mtreichler at onebox.com mtreichler at onebox.com
Fri Sep 14 02:18:08 UTC 2007

I'm a little stuck and looking for some help.
I'm running KnoppMyth R5F1 with 20070820-01 14305 SVN. I have upgraded this machine and other machines to SVN other times.

Trying to compile from source (14490) and getting below errors.

make[1]: Entering directory `/home/mythtv/svn/mythtv/programs'
cd mythtv && qmake mythtv.pro -o Makefile
cd mythtv && make -f Makefile
make[2]: Entering directory `/home/mythtv/svn/mythtv/programs/mythtv'
g++ -c -pipe -march=pentium4 -I/usr/include/kde/artsc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/directfb -D_REENTRANT -Wall -W -fomit-frame-pointer -O3 -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -D__STDC_CONSTANT_MACROS -fomit-frame-pointer -D_REENTRANT  -DMMX -Di386 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DPREFIX=\"/usr\" -DLIBDIR=\"/usr/lib\" -DUSING_X11 -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/share/qt3/mkspecs/default -I. -I/usr/include -I/usr/include -I../.. -I../../libs -I../../libs/libmyth -I../../libs/libmythtv -I../../libs/libavutil -I../../libs/libavformat -I../../libs/libavcodec -I../../libs/libmythupnp -I../../libs/libmythui -I../../libs/libmythlivemedia -I/usr/include/qt3 -I/usr/X11R6/include -I/usr/X11R6/include -o main.o main.cpp
g++  -o mythtv main.o    -L/usr/share/qt3/lib -L../../libs/libmyth -L../../libs/libmythtv -L../../libs/libavutil -L../../libs/libavcodec -L../../libs/libavformat -L../../libs/libmythfreemheg -L../../libs/libmythui -L../../libs/libmythupnp -L../../libs/libmythlivemedia -lmythtv-0.20 -lmythavformat-0.20 -lmythavutil-0.20 -lmythavcodec-0.20 -lmythfreemheg-0.20 -lmythupnp-0.20 -lmythlivemedia-0.20 -lmyth-0.20 -lmythui-0.20 -lfreetype -lz -lmp3lame -lasound -L/usr/lib -lartsc -lgmodule-2.0 -ldl -lgthread-2.0 -lglib-2.0 -ljack -lraw1394 -liec61883 -lavc1394 -lrom1394 -ldirectfb -lfusion -ldirect -L/usr/X11R6/lib -lXinerama -lXv -lXxf86vm -lXrandr -lXvMCW -lXvMC -lqt-mt -lGLU -lGL -lXmu -lXext -lX11 -lm -lpthread
./../libs/libmythtv/libmythtv-0.20.so: undefined reference to `XvMCSurfaceTypes::find(int, int, int, bool, bool, int, int, int, _XDisplay*, unsigned long, unsigned long, unsigned long&, int&)'
./../libs/libmythtv/libmythtv-0.20.so: undefined reference to `glXGetProcAddress'
./../libs/libmythtv/libmythtv-0.20.so: undefined reference to `XvMCSurfaceTypes::has(_XDisplay*, XvMCAccelID, unsigned int, int, unsigned int, unsigned int, unsigned int, unsigned int)'
collect2: ld returned 1 exit status
make[2]: *** [mythtv] Error 1
make[2]: Leaving directory `/home/mythtv/svn/mythtv/programs/mythtv'
make[1]: *** [sub-mythtv] Error 2
make[1]: Leaving directory `/home/mythtv/svn/mythtv/programs'
make: *** [sub-programs] Error 2

I'm using  configuring options. 
./configure --enable-dvb --enable-xvmc --enable-opengl-vsync --enable-xvmc-pro --enable-proc-opt --prefix=/usr   

I also tried running make distclean and redownloading SVN directory and configuring with other options related to OpenGL and XvMC.

Wonder if anyone has any ideas or directions to pursue, I want to upgrade this box for ScheduleDirect changes (nothing like waiting last minute).

Thanks,  Mike


More information about the mythtv-users mailing list