[mythtv-users] ubuntu upgrade to .20.2 failed

Craig Yuen craig.yuen at gmail.com
Fri Sep 14 01:06:29 UTC 2007

i just tried upgrading to the latest .20.2 using the instructions at

when i run the command sudo apt-get upgrade i get the following:

The following packages have been kept back:
  gnupg mytharchive mythdvd mythtv-backend mythtv-common mythtv-database

when i reboot and try to start the backend i get this:

craig at mythbox:/etc/rc5.d$ sudo ./S24mythtv-backend start
Starting MythTV server: mythbackend /usr/bin/mythbackend: error while
loading shared libraries: libmythtv-0.20.so.0: cannot open shared object
file: No such file or directory

it seems i have a mis-match of components, new libraries and old executables

craig at mythbox:/usr/lib$ ls *myth*
libmyth-0.20.2.so.0               libmythfreemheg-0.20.2.so.0.20.2
libmyth-0.20.2.so.0.20            libmythlivemedia-0.20.2.so.0
libmyth-0.20.2.so.0.20.2          libmythlivemedia-0.20.2.so.0.20
libmythavcodec-0.20.2.so.0        libmythlivemedia-0.20.2.so.0.20.2
libmythavcodec-0.20.2.so.0.20     libmythtv-0.20.2.so.0
libmythavcodec-0.20.2.so.0.20.2   libmythtv-0.20.2.so.0.20
libmythavformat-0.20.2.so.0       libmythtv-0.20.2.so.0.20.2
libmythavformat-0.20.2.so.0.20    libmythui-0.20.2.so.0
libmythavformat-0.20.2.so.0.20.2  libmythui-0.20.2.so.0.20
libmythavutil-0.20.2.so.0         libmythui-0.20.2.so.0.20.2
libmythavutil-0.20.2.so.0.20      libmythupnp-0.20.2.so.0
libmythavutil-0.20.2.so.0.20.2    libmythupnp-0.20.2.so.0.20
libmythfreemheg-0.20.2.so.0       libmythupnp-0.20.2.so.0.20.2

how can i fix this ???  i'm running ubuntu 7.04.

thanks in advance.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070913/bfc717d9/attachment.htm 

More information about the mythtv-users mailing list