[mythtv-users] No SD Update and SD Episode Numbers do not match previous recordings

Cottrell, Eric ecottrell at doble.com
Thu Sep 13 18:05:18 UTC 2007


Due to Zap2it going away I finally decided to upgrade to MythTV 0.20.02.  I am having some problems.  Most of them are solved but a couple are still there.  Since I upgraded past September 1 I did not have access to Zap2it to make sure the two setups were in sync.

I was running MythTV 0.16 under SuSE 9.2 with a PVR-250 (IVTV 0.4 driver).  I backed up the database.  I tried compiling and installing 0.20.02 but SuSE 9.2 and the IVTV driver seemed too old to work.  MythTV would hang when trying to create the main menu screen.  So I decided to upgraded everything and use a new hard drive.  This came in handy as I could reference files in the old setup.

Currently I am using SuSE 10.2 with the prepackaged RPMs for MythTV (0.20.02) and IVTV (0.8.0).  I had to compile a new version of LIRC because I needed transmitter capability.  I restored the complete database and changed the tv listings grabber from Zap2it to SD.   I went through the setup menus and checked the settings.  I did a --refresh-all and everything seemed to work okay.  I got 14 days of listings.

I did some searching but do not seem to find any answers.  An archive search feature would be useful to find the information in amongst the 2,000 threads on "Free Listings", "Appropiate Subjects for Posting", and "SD are Criminals/Cheats/Sellouts!!!!!!!!!!".

Problem 1:

Episodes previously recorded are being recorded again.  It appears the the format of the episode codes have changed between Zap2It and SD.  I found mention of this. I thought the schema change updates would correct this?  I verified that the backend updated the database to the current schema via the log.  Do I have to run a utility to correct the episode codes?  I do find the new (to me) previously recorded list very helpful but I do not want to search it every day or two.

Problem 2:

I noticed that mythfilldatabase is not being run.  The status screen shows a date several days ago that was a sucess and I now have 12 days of listings instead of 14.  The setup screen looks correct but it is likely from the 0.16 settings.  Do I have to put full path names to mythfilldatabase now?  Does the mythfilldatabase attempts show up in a log so I can troubleshoot this?

73 Eric

More information about the mythtv-users mailing list