[mythtv-users] RingBuf Error - mythfrontend looking for wrong file during LiveTV AND playing recordings

Mathias Smith mathias.smith at gmail.com
Tue Sep 11 23:06:33 UTC 2007

Any advice or insight most appreciated...

I'm using a combined FE/BE with latest 0.20.2, but this also applies to
0.20.0. Ran smooth for several months on FC6. Then, I tried MythDora 4. It
worked well, but I would occasionally get a frontend "Error displaying
video" error while watching LiveTV. Whenever this occurred it was always
exactly on the half-hour or the hour. Then, I installed latest 0.20.2 on
Ubuntu Feisty a couple days ago, and I'm having the same problems.
Mythfrontend stderr looks like:

2007-09-09 07:30:06.327
Invalid file (fd -1) when opening
2007-09-09 07:30:07.982 NVP, Error: SwitchToProgram's OpenFile failed

Last night, I also noticed this happens with trying to playback a previously
recorded show. When I went to play the show, I also got the same ringbuf
error listed above. Interestingly enough, the show WAS recorded, but under a
slightly different filename.

Mythfrontend was looking for:

But, the show was dutifully recorded in its entirety in:

I looked in the database, and indeed the entry for the recording had a
different filename than that on the disk. Why would mythbackend log the
filename in mysql with a different string than the filename that gets
written to the disk?

I can send any listings or specs that would be helpful...

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070911/47782b05/attachment.htm 

More information about the mythtv-users mailing list