[mythtv-users] No /dev/lirc

Andy Rabin andy.rabin at gmail.com
Mon Sep 10 16:34:52 UTC 2007

Recently setting up a Debian system, I had similar issues.  It turned
out that when lirc was installed, it seemed to work fine, but was
encountering an error.  lirc looks for linux.h in the default
/usr/src/linux directory, but as of 2.6.?? (I know it was an issue
even with 18, not sure how much earlier) linux.h is relegated to a
subdirectory /usr/src/linux/include/linux/linux. (I believe, at work,
can't check right now.)  Creating a symlink to that file in the top
directory, uninstalling and reinstalling lirc, solved the problem for

On 9/9/07, Don Doumakes <doumakes at loganet.net> wrote:
> Peter Watkins wrote:
> > On Sun, Sep 09, 2007 at 01:16:02AM -0500, Don Doumakes wrote:
> >
> >>Peter Watkins wrote:
> >>
> >>>If you're using the StreamZap USB receiver, you want the
> >>>lirc_streamzap kernel module, not lirc_mceusb2.
> >>
> >>Beautiful.  Now there's a /dev/lirc0, and irw runs without blowing up
> >>lircd, which is definite forward progress.  There's no output to the
> >>console when I press buttons on the remote, though.  Guess I could use a
> >>second clue.
> >
> >
> > You're running irw as root (for now)? Does the LED on the StreamZap
> > receiver illuminate when you send codes? Have you tried other remote
> > controls you have lying around? (I actually have not used the StreamZap
> > remote itself; my universal remote emulates the old Hauppauge PVR-350
> > remote that I used in my first MythTV system.)
> Yes running it as root, but it also works as the mythtv user.  And by
> "works" I mean yes, the LED lights up when any remote at all is pointed
> at the StreamZap, but no output from irw, which is troubling.
> >
> >>lsmod | grep lirc
> >>lirc_streamzap         17540  0
> >>lirc_dev               18504  1 lirc_streamzap
> >>usbcore               154416  7
> >>pl2303,usbserial,lirc_streamzap,usbhid,ohci_hcd,ehci_hcd
> >
> >
> > That looks right. My Feisty system has other modules depending on
> > usbcore (to be expected), but that's what my module list looks like,
> > including the size column.
> Perhaps I should just write off the unexpected behavior from irw, and
> set up a lircrc then.
> --
> Don Doumakes
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users


If we weren't all crazy we would go insane!
                                         -Jimmy Buffett

More information about the mythtv-users mailing list