[mythtv-users] Problems with myth2ipod - nuvexport and MP4Box (and, apparently, ffmpeg)

Brad DerManouelian myth at dermanouelian.com
Mon Sep 10 15:23:10 UTC 2007

On Sep 10, 2007, at 8:03 AM, Dan Brown wrote:

> Hash: SHA1
> Brad DerManouelian wrote:
>> I ended up hacking up myth2ipod to execute the same commands as
>> worked from the command line and left it as that.
> Well, the time that it worked, I was using it interactively.  I tried
> running the logged nuvexport command line, and ffmpeg failed.
> Re-running nuvexport in debug mode, it spit out this command line for
> ffmpeg:

It seems unusual that the command in the nuvexport log works  
interactively but not when you use it from the command line manually.

I'm using an older version of ffmpeg (FFmpeg version SVN-r8743). I  
know some stuff has changed recently and you might need to upgrade  
nuvexport to pass the correct flags like in this thread:

I'm just guessing, but I hope this helps.

Here's what I get when I do a -formats | grep 264:

[mythtv at mythtv ~]$ ffmpeg -formats | grep 264
FFmpeg version SVN-r8743, Copyright (c) 2000-2007 Fabrice Bellard, et  
   configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/ 
lib64 --mandir=/usr/share/man --enable-shared --enable-gpl --enable- 
pp --enable-swscaler --enable-pthreads --enable-x11grab --enable- 
dc1394 --enable-liba52bin --enable-libdts --enable-libfaac --enable- 
libfaadbin --enable-libmp3lame --enable-libogg --enable-libtheora -- 
enable-libvorbis --enable-xvid --extra-cflags=-O2 -g -pipe -Wall -Wp,- 
D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer- 
size=4 -m64 -mtune=generic -fPIC --disable-strip
   libavutil version: 49.4.0
   libavcodec version: 51.40.3
   libavformat version: 51.12.1
   built on Apr 23 2007 23:28:07, gcc: 4.1.1 20070105 (Red Hat 4.1.1-51)
  DE h264            raw H264 video format
  D V DT h264

More information about the mythtv-users mailing list