[mythtv-users] MythTV Upgrade FC5 --> F7 ... A Story of Hope

George Rocklein grocklein at comcast.net
Mon Sep 10 03:08:07 UTC 2007

I figured I'd offer my little tale of a successful upgrade (so far, at 
least) in case any part of it proves to be helpful (or hopeful) to someone.

I was running MythTV 0.20 on FC5, and wanted to upgrade to 0.20.2 for 
SchedulesDirect purposes.  I originally considered just staying on FC5, 
and upgrading MythTV via yum.  However, since atrpms support of FC5 went 
away a few months ago, I was left with the prospect of installing .20.2 
from source -- and I'm still enough of a noob that I was sure I'd find a 
way to screw that up.

So, I decided the best course of action for me would be to just upgrade 
my system to FC7, and then take advantage of atrpms from there.

First off, I opted to ignore all the smart advice about backing up my 
mysql database and recordings -- and chose to just barge ahead with the 
upgrade.  (Probably not the advisable path for most people, but I was 
feelin' frisky.)

Here are the basic steps I took:

1.  I upgraded using an FC7 DVD I still had lying around.
2.  I disabled all my 3rd-party repositories except atrpms.
3.  I ran yum upgrade against my system (this put me on kernel
4.  I installed the nvidia-graphics9755 drivers to have something more 
recent than what I had been working with.
5.  I made sure my original xorg.conf was being used.
6.  After rebooting and getting various video complaints, I uninstalled 
the older drivers.
7.  Upon starting up MythTV, x-server immediately blew up on me.
8.  I scanned through the mythtv-users mail archive at gossamer-threads, 
and found that I needed to add the following lines to my original xorg.conf:

       ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
       ModulePath "/usr/lib/xorg/modules/extensions/"
       ModulePath "/usr/lib/xorg/modules/"

(I don't know how long I would have taken to figure this out on my own 
-- I'm thinking I may have begun contemplating rebuilding everything 
before I solved that one)

9.  After fixing my xorg.conf per step #8, I rebooted, started MythTV, 
and basically everything worked and was intact.  I still need to get 
lirc working again, as well as the wifi card I have installed, but 
otherwise all appears to be well.  I also still need to configure SD, 
but that sounds like a trivial exercise (famous last words -- my 
personal road to Hell is usually paved with things I expect to be 
trivial exercises).

Anyway, that's my story.  It all went about as well as I could have 
expected.  Thanks to all the contributors to this mailing list who have 
unknowingly helped me with my MythTV issues/questions over the past 
couple of years.

-- George


More information about the mythtv-users mailing list