[mythtv-users] spontaneous reboots after upgrade & move to Ubuntu - IVTV/pre-emptive kernel locks?

Peter Watkins peterw at tux.org
Sat Sep 8 00:01:34 UTC 2007

A couple weeks ago I upgraded my 0.19 system (based on Fedora Core 4 
i386 & Jarod's guide) to 0.20.x on Ubuntu 7.04 amd64, in preparation for 
Schedules Direct.

The system has been spontaneously rebooting ever since -- uptime between 
7 minutes and 9 hours. Before this change, it was rock solid. Sometimes 
the HD3000/DVB tuner would fail (and record 0 bytes), but the hardware & 
OS were very stable. It /seems/ less stable when recording SD shows via 
IVTV and my PVR 500, but it /has/ successfully recorded some two hour 
movies, so it's not failing predictably.

I've tried to test a number of components and came across the 
MythTV/IVTV wiki entry warning "Do /not/ attempt to enable pre-emptive 
kernel locks in your kernel configuration--the ivtv modules do not get 
along with them and will cause /spontaneous reboots/." Is this possibly 
what I'm seeing? How can I tell: first, if my amd64 kernel supports 
pre-emptive kernel locks, and, second, if that's enabled? And can I 
disable them through /proc or a boot option?

What has changed:
I replaced two older ATA drives (replaced Seagate 200G and 250G with a 
matched pair of Seagate 500G), added a 1GB memory module (now has 2 GB 
RAM), and installed an additional 120mm case fan to help cool the drives 
& system. Instead of Fedora Code  4 i386 on /dev/hda I now have Ubuntu 
7.04 amd64 running on md raid (raid1 for /boot and /) -- which also 
means many upgraded software packages, including IVTV and NVidia 
drivers. I've replaced the 18 month old Antec TruePower II 550w power 
supply with a new Sea Sonic 550w supply.

The RAM checked out fine with an ~18 hour memtest86+ run. No errors have 
been reported on the drives by partitioning tools, SMART tools, etc. 
I've tried removing the new RAM, moving the RAM around and disconnecting 
the new case fan. I have disconnected a seldom-used SCSI tape drive and 
physically removed its host adapter. I switched SATA power cables for 
the SATA drives that I am still using. I have run StressCPU from UBCD 
for over three hours without trouble. I have not tried disconnecting 
either of the new 500G hard drives. The system temperature looks OK. 
There's no lm_sensors support, but when rebooting after normal use, the 
system temp is usually around 40 C and the CPU temp around 45 C. As 
stated above, I have replaced the power supply. I have run a 'cp' for a 
4 GB file in a while [] loop to test the disk/md/lvm.

Considering the previous stability, the new power supply, the success 
with memtest86+, and the results of my hardware tests, it seems very 
plausible that I'm having software trouble.

System details:
Athlon64 with 2 ATA and 2 SATA hard drives, using LVM atop "md" RAID1 
arrays for the MythTV recordings (MySQL data is on the simple raid1 md 
array for /). PS is a 550w Sea Sonic  S12, which gets AC through an APC 
UPS. Video is an Nvidia 6200 LE (AGP), feeding the TV via DVI, using the 
Nvidia binary driver (rev 9631, I believe -- the version suggested by 
Ubuntu's proprietary driver manager app, using NvAGP "2" for better 
picture quality). Three PCI cards: a pcHDTV HD3000 tuner used for ATSC, 
a Hauppauge PVR-500 used for SD/cable, and an old Ensoniq 1371 sound 
card. One DVD-RW on the second IDE channel, and, yes, a floppy drive. 
I'm running the Ubuntu kernel "2.6.20-16-generic #2 SMP Thu Jun 7 
19:00:28 UTC 2007 x86_64 GNU/Linux" and Ubuntu's IVTV 0.10.1. The config 
for that kernel (in /boot) has the following "preempt" kernel settings:

# CONFIG_PREEMPT is not set

Also, sometimes Ubuntu fails to boot, dropping me to a busybox prompt 
(looks like this problem, but the piix initramfs approach has not 
sufficed for me: 
I haven't tried the quiet/splash/irqpoll boot settings yet). With the 
UPS, I'm not too worried about this; I only mention it in case someone 
thinks it relevant to the spontaneous reboots.

Any help appreciated!


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070907/02af2ba9/attachment.htm 

More information about the mythtv-users mailing list