[mythtv-users] Digital channel ordering

Ron Garrison ron.garrison at gmail.com
Fri Sep 7 03:07:57 UTC 2007

On 9/4/07, Nedim Cholich <mythtv at cholich.com> wrote:
> I was lucky to have tone of digital channels on my cable (QAM) when I
> moved so I got the HDHomeRun recently to complement the pvr500 I already had
> in the system. For the last couple of days I was going through the ordeal of
> mapping channels to their real numbers/names.
> Back when I had hd2000 I remember digital channels showing up correctly in
> FE. Like, 4 WNBC comes before 4.1 WNBCHD etc. Now I have channels sorted
> seemingly in random order. The SD channels are sorted fine, but digital
> channels are all over the place. I triple checked my ordering preferences
> and for the life of me I can't figure out what logic FE is using to sort the
> channels. I tried numbering digital channels like 4.1 and 4#1.
> The only thing that worked properly was giving digital channel the same
> number but different call letters, i.e. 4 WNBC, 4 WNBCHD and different
> xmltvid. Then they showed up together. Is there any problem with having
> different channels have the same channum? Is there any other way of doing
> this? To make things worse Mythweb is behaving differently and using this
> scheme makes digital channels disappear in the listing (they are still there
> in the channel lineup). I guess Mythweb only uses channel numbers and since
> there are duplicates, it removes the new channels.
> Is the problem coming from the fact that channum in the db is varchar and
> not a number, so 'order by' doesn't work as expected
> Overall, I have to say that I'm pretty impressed with HDHR so far. The
> only glitch is that most of the time watching live HD program is not
> possible due to hickups and lag. Oddly enough watching same program on my
> laptop in vnc over wifi works better!? I guess there is no disk r/w
> involved. But recorded show play beautifully with no problems so far (cross
> my fingers).
> Thanks for any insight.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

I had this problem as well.  Its more of a problem with cable as the channel
is ordered by the OTA number as opposed to the cable reassignment.  Anyhow -
I came across the following patch and it has worked perfectly for me.

I might mention that I also like my guide revresed from the normal display
(lower channels at the bottom of the screen) because its more logical for me
to hit channel up and have the cursor move up and the channel increments.
Its a very simple update if anyone is interested.

Anyhow I found the script here:


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070906/944d9a72/attachment.htm 

More information about the mythtv-users mailing list