[mythtv-users] lirc - Can not connect to socket after following how-to

Bearcat M. Sandor HomeTheater at feline-soul.com
Wed Sep 5 17:01:34 UTC 2007


I'll go through that set-up and see what happens.  My distro (Sourcemage) also 
provides a script for the config options and i'd bet they are the same. I'll 
go through it and check.

Thank you. Funny that i never thought of checking the instructions that came 
with the source code. Usually the consist of config-make-make install.  

Bearcat M. Sandor
On Wednesday 05 September 2007 in an email titled "Re: [mythtv-users] lirc - 
Can not connect to socket after following how-to" Michael Jones wrote:
>On Sep 4, 2007, at 2:26 PM, Bearcat M. Sandor wrote:
>> Folks,
>> I'm struggling with lirc.  I have posted this to the lirc list as
>> well and
>> have gotten no replies yet. I'm hoping someone here can help me out. I
>> want to control my dishnetwork box with mythtv and my keyboard.
>> Thanks all.
>> ---------
>> Folks,
>> I've been struggling with lirc all day and i am a bit frustrated
>> and looking
>> for help.
>> I have compiled everything from source (using the Sourcemage
>> distro). I am on
>> kernel 2.6.22 (x86_64).
>> I have been following the instructions at
>> http://www.eggshellskull.com/lirc/blaster/index.php , however this
>> person
>> seems to have a remote control and an ir blaster, where as i only
>> have a
>> Light Up RS232 IR Blaster. I just want to be able to send commands
>> to MythTv
>> through my keyboard.
>> Although he says i should have 5 files in /dev (lirc, lirc0, lirc1,
>> lircd,
>> lircd1) i have 4 (lirc, lircd, lircd1, lircdm). I'm confused by the
>> fact
>> that i don't have an lirc0 and i have an lircd1.
>> Since i am *only* using the serial port for this i assume the items
>> corresponding to lircd_i2c do not apply to me.
>> If i do a "modprobe lirc_dev" and "modprobe lirc_serial" i get no
>> errors.
>> Then when i do
>> a "/usr/sbin/lircd --driver=default --device=/dev/lirc
>> --output=/dev/lircd1 --pidfile=/var/run/lircd1.pid"
>> i see "lircd(serial) ready"
>> However doing a "irsend --device=/dev/lirc SEND_ONCE dish 08" gives
>> me "irsend: could not connect to socket irsend: Connection refused"
>> Doing the above command with /dev/lircd, /dev/lircd1 or /dev/lircm
>> give me
>> the
>> same result. My Light Up RS232 IR Blaster never turns red.
>> I have tried recompiling lirc with Com2, but my motherboard header
>> is marked
>> as "COM1".
>> All of my /dev/lirc* are mode 666. All commands and tests have been
>> run as
>> root.
>> Thanks all.
>> My config files are as follows:
>> --------------------
>> /etc/modprobe.conf:
>> #20080901-bms-load up stuff for lirc to control DishNetwork reciever
>> alias char-major-61-0 lirc_serial
>> options lirc_serial irq=4 io=0x3f8
>> ####IR setup####
>> ##install lirc_i2c /sbin/modprobe ivtv; /sbin/modprobe --ignore-
>> install
>> lirc_i2c
>> install lirc_serial setserial /dev/ttyS0 uart
>> none; /sbin/modprobe --ignore-install lirc_serial
>> -----------------------------
>> /etc/sysconfig/bootmisc (loaded at boot time instead of putting it
>> in it's
>> startup script):
>> <snip> unrelated to lirc</snip>
>> #20070901-bms-Start lirc server
>> /sbin/modprobe lirc_dev
>> /sbin/modprobe lirc_serial
>> /usr/sbin/lircd --device=/dev/lirc0 --output=/dev/lircd
>> /usr/sbin/lircd --driver=default --device=/dev/lirc1 --output=/dev/
>> lircd1
>> --pidfile=/var/run/lircd1.pid
>> -----------------------
>> I won't post my entire lircd.conf (as i'm not that far along
>> anway), but the
>> first few lines are:
>> begin remote
>> name dish
>> ------------------------------
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>Take a look here:
>The version of lirc referenced here includes a setup script that
>walks you through the config portion to set up the software, then
>just make and make install.   It worked with my MCE remote as well as
>the remote receiver on the Hauppauge cards.   From the looks of it,
>it has configuration capabilities for a significant number of options.
>- Michael
>mythtv-users mailing list
>mythtv-users at mythtv.org

More information about the mythtv-users mailing list