[mythtv-users] lirc - Can not connect to socket after following how-to

Bearcat M. Sandor HomeTheater at feline-soul.com
Tue Sep 4 21:26:01 UTC 2007


I'm struggling with lirc.  I have posted this to the lirc list as well and
have gotten no replies yet. I'm hoping someone here can help me out. I
want to control my dishnetwork box with mythtv and my keyboard.

Thanks all.

I've been struggling with lirc all day and i am a bit frustrated and looking
for help.

I have compiled everything from source (using the Sourcemage distro). I am on
kernel 2.6.22 (x86_64).

I have been following the instructions at
http://www.eggshellskull.com/lirc/blaster/index.php , however this person
seems to have a remote control and an ir blaster, where as i only have a
Light Up RS232 IR Blaster. I just want to be able to send commands to MythTv
through my keyboard.

Although he says i should have 5 files in /dev (lirc, lirc0, lirc1, lircd,
lircd1) i have 4 (lirc, lircd, lircd1, lircdm). I'm confused by the fact
that i don't have an lirc0 and i have an lircd1.

Since i am *only* using the serial port for this i assume the items
corresponding to lircd_i2c do not apply to me.

If i do a "modprobe lirc_dev" and "modprobe lirc_serial" i get no errors.
Then when i do
a "/usr/sbin/lircd --driver=default --device=/dev/lirc
--output=/dev/lircd1 --pidfile=/var/run/lircd1.pid"
i see "lircd(serial) ready"

However doing a "irsend --device=/dev/lirc SEND_ONCE dish 08" gives
me "irsend: could not connect to socket irsend: Connection refused"
Doing the above command with /dev/lircd, /dev/lircd1 or /dev/lircm give me
same result. My Light Up RS232 IR Blaster never turns red.

I have tried recompiling lirc with Com2, but my motherboard header is marked
as "COM1".

All of my /dev/lirc* are mode 666. All commands and tests have been run as

Thanks all.

My config files are as follows:
#20080901-bms-load up stuff for lirc to control DishNetwork reciever
alias char-major-61-0 lirc_serial
options lirc_serial irq=4 io=0x3f8
####IR setup####
##install lirc_i2c /sbin/modprobe ivtv; /sbin/modprobe --ignore-install
install lirc_serial setserial /dev/ttyS0 uart
none; /sbin/modprobe --ignore-install lirc_serial
/etc/sysconfig/bootmisc (loaded at boot time instead of putting it in it's
startup script):
<snip> unrelated to lirc</snip>
#20070901-bms-Start lirc server
/sbin/modprobe lirc_dev
/sbin/modprobe lirc_serial
/usr/sbin/lircd --device=/dev/lirc0 --output=/dev/lircd
/usr/sbin/lircd --driver=default --device=/dev/lirc1 --output=/dev/lircd1
I won't post my entire lircd.conf (as i'm not that far along anway), but the
first few lines are:
begin remote
name dish

More information about the mythtv-users mailing list