[mythtv-users] Trying to use HDTV as a firewire recorder

Bob mythtv at cox.net
Tue Sep 4 03:46:48 UTC 2007

Andrew Burgess wrote:
>> I have a Samsung HDTV with both a cable card and IEEE1394 ports.  For
>> the past several months I have been able to use test-mpeg2 and "at" to 
>> record shows.  Of course, this has many limitations.
> Cool!
>> I have set-up my TV as an "OTHER" firewire box.  I created a "channel 
>> changer" program that will power-up the TV (IR blaster), set the input 
>> to "TV", tune to the appropriate channel, and "prime" the firewire using 
>> test-mpeg2.  The problem is that the backend appears to be recording, 
>> but the file is always 0 bytes.
> I've had better priming luck with firewire_tester and myth_prime
> both available as C files on the web. myth_prime includes a
> /etc/sysconfig/mythbackend file to prime automatically
> when the backend starts. You don't need to prime before every recording.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
I have downloaded an used the peer-to-peer prime script you suggested.  
It appears to "prime" the TV, but I am still unable to get mythtv to 
save a stream to disk.  I have also tried broadcast mode which does not 
work at all in my case.

Here is an example on my backend log:

2007-09-03 20:38:31.989 External Tuning program exited with no error
2007-09-03 20:38:32.002 Started recording: Get Fresh With Sara Snow 
"Green Yard": channel 4103 on cardid 6, sourceid 4
libiec61883 warning: Established connection on channel 0.
You may need to manually set the channel on the receiving node.
2007-09-03 20:38:32.022 FireRec: Buffered packets 2000 (8000 KB)
2007-09-03 20:45:00.771 TVRec(6): Changing from RecordingOnly to None
2007-09-03 20:45:00.782 Finished recording Get Fresh With Sara Snow 
"Green Yard": channel 4103
2007-09-03 20:45:00.784 Reschedule requested for id 0.
2007-09-03 20:45:00.992 Finished recording Get Fresh With Sara Snow 
"Green Yard": channel 4103
2007-09-03 20:45:01.003 Preview Error: Previewer file 
'/myth/tv/4103_20070903203800.mpg' is not valid.

It appears to have recorded but the file is zero bytes.  I tried similar 
tests again at the 3 different connect speeds (100, 200, 400) but I get 
the same result.  While recording if I run "plugreport" I can see that 
n_p2p_connections=1 and it is zero when not recording.

The firewire_tester script makes 15 connection attempts and works all 15 
times in every attempt I made to record.

As I stated above, I have good success using test-mpeg2, but this has a 
very low WAF.  I'd appreciate more suggestions.

More information about the mythtv-users mailing list