[mythtv-users] SD-Mythfilldatabase problem

Michael T. Dean mtdean at thirdcontact.com
Sat Sep 1 23:49:02 UTC 2007

On 09/01/2007 07:28 PM, Vince Busam wrote:
> mythfilldatabase runs but reports errors.  It does not update my program
> guide.  FC6, 0.20.2-164 from ATRPMS, just upgraded myth yesterday
> afternoon.
> When I setup my account with SD, I needed to use my email address so it
> has a different userid and password than I had been using with Zap2It.
> Could this be the problem?

No.  That's why you entered your new userid/password when you changed
the grabber to the SD grabber.

> I followed the instructions at
> http://www.mythtv.org/docs/mythtv-HOWTO-24.html#ss24.3 but I still have
> only 12 days of data event even though Information Center / System
> Status / Listing Status on mythfrontend shows a successful
> mythfilldatabase just occured.
> Mythfilldatabase output shows HTTP errors and a dd_state error.
> Any suggestions?  Thanks, Vince
> Here is my output from mythfilldatabase:
> 2007-09-01 15:23:05.873 Grabbing listing data
> --15:23:05--
> http://webservices.schedulesdirect.tmsdatadirect.com/schedulesdirect/tvlistings/xtvdService
> Resolving webservices.schedulesdirect.tmsdatadirect.com...
> Connecting to webservices.schedulesdirect.tmsdatadirect.com|
>|:80... connected.
> HTTP request sent, awaiting response... 401 Unauthorized
> Reusing existing connection to
> webservices.schedulesdirect.tmsdatadirect.com:80.
> HTTP request sent, awaiting response... 500 Internal Server Error
> 15:23:06 ERROR 500: Internal Server Error.
> 2007-09-01 15:23:06.427 Grab complete.  Actual data from  to  (UTC)

The 401 is normal.  The 500 means an error on the server side.  This
could be due to the onslaught of users switching their systems at the
last minute or may be due to an invalid configuration.

You did tell mythtv-setup to get the lineups and select the appropriate
lineup after you changed the grabber in the video source, right?


More information about the mythtv-users mailing list