[mythtv-users] Nova-T 500 musings...

James Fidell james at fidell.co.uk
Sat Oct 27 23:44:46 UTC 2007

Anyone else have a Nova-T500 tuner and still getting mt2060 I2C write

I'm running CentOS5 (2.6.18 kernel + RedHat updates) with new v4l-dvb
drivers taken from linuxtv.org a couple of weeks ago and the latest
firmware.  I still get mt2060 I2C read and write errors.  As far as I
can tell the read errors don't seem that serious, but the write errors
seem to break tuning somehow so that I end up with a failed recording.
Thus far I've resolved this by stopping mythbackend and unloading and
reloading all the dvb modules whenever I've seen a writer error.  This
seems to work ok, but it's a pita.

Yesterday, more out of irritation than any real understanding of the
code, I changed the mt2060 driver code that calls write_regs to retry
if the first attempt fails.  Thus far I've had a couple of fails that
have worked ok on the second attempt and I've had no failed recordings.

I'll be watching things over the next few days to see what happens.
What I've done is without doubt a hack rather than a genuine fix, but
if it mostly resolves the problem for me, I think I can live with that
until such time as someone who understands the problem properly can
do the job right.


More information about the mythtv-users mailing list