[mythtv-users] Can't watch live TV over firewire

Matt Emmott memmott at gmail.com
Sun Oct 7 03:52:12 UTC 2007

On 10/1/07, Allan Wilson <allanwilson at gmail.com> wrote:
> Also using test-mpeg2 you can use your remote to set it to a channel and
> make sure you are recording video before you try it in mythtv-setup.

Ok, this is interesting. The PC had been off for a couple days. After
turning it on I ran firewire_tester succesfully:

[root at magic contrib]# ./firewire_tester -p -n 0 -r 5
Action: Test P2P connection 5 times, node 0, channel 0
P2P: Testing...Success, 226 packets received
P2P: Testing...Success, 631 packets received
P2P: Testing...Success, 258 packets received
P2P: Testing...Success, 257 packets received
P2P: Testing...Success, 259 packets received

I then ran test-mpeg2 > test.mpg and was able to view the captured mpeg in
mplayer. Everything good, I fired up Myth and tried watching live tv. Same
result - It would tune to channel 560 and then dump me back to the myth
interface, same errors as before.

But I decided to test recording for the heck of it. I went to manage
recordings - scheduled recordings and told it to record SNL. I let it run
for a few seconds and tried watching the recording - Blank screen. I
manually changed the channel via the cable box remote, and surprisingly,
video started to show up. Even more interesting, it was Cinemax HD. I cycled
through channels via the remote and am able to watch all the premium
channels, both HD and non HD. The non HD channels have some tearing with a
Prebuffering Pause error in the terminal, but I'm not worried about that for

Right now I'm trying to figure out why it won't let me watch Live TV or
succesfully change channels. Any ideas?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20071006/e20b0edd/attachment-0001.htm 

More information about the mythtv-users mailing list