[mythtv-users] Getting lirc working on a Logitech Harmony 550

Harry Devine lifter89 at comcast.net
Thu Oct 4 01:25:34 UTC 2007

Brian Walter wrote:
> Harry Devine wrote:
>> I just got an IR Blaster receiver from irblaster.info, and have a 
>> Logitech Harmony 550 remote.  I'd like to get the remote working via 
>> lirc to control my Myth box.  Does anyone have any tips/tricks/gotchas 
>> on how I can go about getting this working?  I installed Myth with lirc 
>> support when I initially set it up (in anticipation of getting a remote 
>> working at some point), but I'm sure that I'll have to tweak a few 
>> things here and there.  I read somewhere (maybe even in the Wiki) that 
>> the Harmony remotes  can be set to emulate a Hauppauge remote, but I'm 
>> not sure exactly how to do that.
>> Thanks for any help,
>> Harry
> Harry,
> Not *exactly* sure about that particular model, but, the two Harmony's I 
> have you set up via a web interface.  You pick the devices and the 
> activities you want, and create activity buttons.
> Given that, you can pick in essence anything you want to create your 
> PVR/TV combo, and load the remote.  Once done, then you you use irrecord 
> to record the buttons you want, and create the lircd.conf file.
> If I remember correctly, I picked my TV and a tivo and used those, then 
> trained lirc to know what the buttons mean.
> Brian
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
I just tried to setup my remote as the Hauppauge PVR-350.  I told MythTV 
that my remote was an Hauppauge one (I used the "Rerun setup" under 
Mythdora Tools), even though it never asked me which one (just said "the 
NEW one with the grey, etc.").  I also put an lircd.conf, lircmd.conf, 
and lircrc-haupgrey-g3.txt file that a friend of mine uses up under /etc 
and restarted the lircd daemon.  I don't get anything.  The remote 
doesn't control the Myth box at all.

What am I missing?  You said that you had to "train" the remote.  I 
thought that by having the commands in the lircd.conf file, that it was 
already trained.  Sorry if this sounds trivial, but I've had a really 
hard time getting stuff on this box to work right.  It's not as easy as 
I've read others say, that's for sure.

I can put copies of the files mentioned above into another reply if 
anyone cares to look at them.


More information about the mythtv-users mailing list