[mythtv-users] WakeOnAlarm still not working

Peter Carlsson maillist.peter at home.se
Thu Nov 29 10:05:26 UTC 2007


A while back I asked for help about my problems with Wake On Alarm.
I have not yet solved the problem, but I feel I am getting closer
and closer...

I have tried to follow this excellent guide:

It is written for Ubuntu though I use Debian. 

Setting the wake up time in BIOS and turning off the computer with
the case button works.

Setting the wake up time in /proc/acpi/alarm and doing either
'shutdown -h -P now' or 'shutdown -h -H now' does not work.

I have also tried with the special kernel image which only purpose
is to do a reboot before shutdown. That does not work either.

I was suggested to modify /etc/init.d/halt to set /proc/acpi/alarm
after setting the hwclock. But in Debian this seems to be handled
in the /etc/init.d/hwclock.sh and /etc/init.d/hwclockfirst.sh, which
I have both modified according to the guide above.

I have also used cat_nvram (part of nvram_wakeup) to verify that
what I write to /proc/acpi/alarm actually get written to NVRAM,
which it does.

Could there be any installed packages in conflict with what I am
trying to do? I have manually installed the following packages:
  powersaved, nvram-wakeup, hibernate, acpid

Any thoughts or suggestions?

Best regards,
Peter Carlsson

More information about the mythtv-users mailing list