[mythtv-users] Compiling latest SVN

Harry Devine lifter89 at comcast.net
Fri Nov 23 16:54:49 UTC 2007

Michael Rice wrote:
> On Nov 23, 2007 8:19 AM, Harry Devine <lifter89 at comcast.net> wrote:
>> I just did both steps, and got the same issues.  I ran "service
>> mythbackend restart" and got an error stating "unrecognized service".
>> Obviously something's missing, I just can't seem to figure out what.
> When you removed the ATRPMS package it probably took out the startup
> script in /etc/init.d.
> What I did to upgrade to SVN from ATRPMS packages:
> 1. Build/install with --prefix=/usr/local
> 2. Add to ld.so.conf as state above
> 3. rm -f /usr/bin/myth* (and any other myth executables)
> 4. rm -rf /usr/lib/libmyth (and any other myth stuff)
> Just make sure you have no myth files in /usr/bin and /usr/local and
> try mythbackend from the command line.  If still getting an error
> check permissions and check that /usr/local is in /etc/ld.so.conf.

I did options 1 and 2 already as you suggested.  I don't see any myth 
files under /usr/bin or /usr/lib, but I do have myth files under 
/usr/local/bin since this is where I told the make install to go (via 
--prefix=/usr/local).  I still get those errors.  Also, my ld.so.conf 
has /usr/local/lib as the last line (as per suggestion 2 above).  As for 
permissions, I compiled and installed as root, so the files under 
/usr/local/bin are owned by root.  Should these be owned by the mythtv 
user and group?


More information about the mythtv-users mailing list