[mythtv-users] Upgrading question

William Munson william_munson at bellsouth.net
Thu Nov 22 11:24:08 UTC 2007

Harry Devine wrote:
> Sean Goodpasture wrote:
>> On Nov 21, 2007 8:09 PM, Harry Devine <lifter89 at comcast.net 
>> <mailto:lifter89 at comcast.net>> wrote:
>>     William Munson wrote:
>>     > Harry Devine wrote:
>>     >> I was thinking about upgrading my Myth box to the latest version,
>>     >> mainly because I'd like to get the updated Mythweather.  I was
>>     >> looking around on Axel's atrpms.net <http://atrpms.net/> site
>>     and saw that the latest
>>     >> packages available for FC6 are 0.20.2-168.fc6.  So, I checked my
>>     >> versions and found the following:
>>     >>     mythfrontend -> 0.20.2-163.fc6
>>     >>     mythbackend -> 02.20.2-163.fc6
>>     >>
>>     >> With this, I have 2 questions:  1)  Whats the proper way to upgrade
>>     >> my system?  Will 'yum update mythtv' work?  2)  How can I
>>     determine
>>     >> the plugins versions?  Will updating via yum also update the
>>     plugins?
>>     >>
>>     >> Thanks,
>>     >> Harry
>>     >>
>>     >>
>>     >
>>     > FC6 is end-of-life and no longer updated. I had no serious problems
>>     > switching to F8 although the switch did redo where the various
>>     drives
>>     > mapped. Not a big deal but you should be aware of it.
>>     >
>>     >
>>     >
>>     I installed my box with Mythdora, so I'll have to check if they
>>     have any
>>     updates for F8.  If not, how did you upgrade?  Did you upgrade to a
>>     stock F8 installation, then add Myth afterwards?  Did you pull in the
>>     latest packages from atrpms?  I assume that I'd have to tuck my
>>     database
>>     away somewhere if I went this route, correct?
>>     Thanks,
>>     Harry
>>     _______________________________________________
>>     mythtv-users mailing list
>>     mythtv-users at mythtv.org <mailto:mythtv-users at mythtv.org>
>>     http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>> Since you used Mythdora, just run yum upgrade \*myth\* and you'll get 
>> something new :-) 
> I just tried that and got error messages similar to the following (after 
> all the upgraded packages were downloaded):
> "file /usr/include/mythtv/util.h from install of 
> mythtv-devel-0.20.2-169.fc6 conflicts with file from package 
> libmyth-devel-0.20.1-156.3.md4"
> One thing that I didn't do was stop either the frontend or backend (I'm 
> doing this via an SSH connection).  This probably matters to some 
> extent, but do you have any other ideas?

Since you are running a "package" system that has not been updated by 
the author lately, there are 2 choices.

1) Manually upgrade by changing your yum FC6 repo's to F8 repo's and 
upgrade everything manually. Pain in the butt but will retain all your 
settings and recordings.

2) Switch "packages". I would suggest that you check out MythUbuntu 
which was recently upgraded to "Gutsy" and which has a much longer 
lifetime left. Issue is that you will need to wipe and start over. Of 
course if your recordings are on a different drive than your linux 
install then all you need to do is dump your database and save it 
somewhere safe to be able to restore your settings.


More information about the mythtv-users mailing list