[mythtv-users] lirc not changing channels

K Barter kbarter at gmail.com
Mon Nov 19 19:34:44 UTC 2007

Here is my channel change script.  It is the same that I have been using for
the past 11 months on my old distribution:

REMOTE_NAME=telustv  # Define remote name here

for digit in $(echo $1 | sed -e 's/./& /g'); do # Accept input from MythTV
irsend --device=/dev/lircd SEND_ONCE $REMOTE_NAME $digit # Send the output
to Lirc
sleep 0.4 # note, you may have to tweak the interdigit delay up a bit # Wait
for next digit
done # got last digit from MythTV

When the script executes, I see the red light on the IR transmitter blink
for each digit.  It just seems that the tv box does not pick up the
signals.  I have tried 2 different blasters and different serial ports, all
with the same result.  I do not have an alternate lircd.conf file for
TelusTV, or I would have tried that too.

Thanks for the help...
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20071119/6b0f89cb/attachment.htm 

More information about the mythtv-users mailing list