[mythtv-users] MythWeather revamp

Bruce Taber brutab at verizon.net
Mon Nov 19 14:07:09 UTC 2007

Having a problem getting the mythweather revamp screens to work. Running 
21-trunk installed from atrpms using yum. That equates to the svn 14785 
version. The specific problem is on the Screen Setup where the desired 
inactive screens are selected and added to the active screens list. Get 
there by Utilities/Setup->Setup->Info Center Settings->Weather 
Settings->Screen Settings. The screens can be selected from the inactive 
list but it's not possible to arrow down to the active list to then do 
the source setup. The arrow down goes from the last item in the inactive 
screens list to the Finish button. When the Finish button is pressed 
there's a popup dialog box with a list of modules with the message 
"Cannot proceed, the following do not have sources defined:", the list 
of sources, and an okay button.

I've found this information in the archives 
(http://www.gossamer-threads.com/lists/mythtv/users/265547) but 
everything looks okay from the things to check. All of that isn't listed 

... Now, as far as the source stuff... For one, make sure that all of 
the *.pl scripts
are executable in /usr/share/mythtv/mythtweather/scripts. Now, with all
of that set:
1. start up your frontend and go to "Utilities/Setup"->"Setup"->"Info
Center Settings"->"Weather Settings"->"Screen Settings".
2. Arrow down to the first item in your list of "Active Screens".
3. Now, with the first one highlighted, hit "ENTER", and a new menu will
4. Select "Change Location" to bring up the search page. Enter in your
location (unfortunately, this part is a bit specific to the NWS, so take
a peel in the NWS-Stations.xml file for something close to you) and hit
search. Select your location from the search results and hit "enter".
This will close the search window and move focus back to the list of
"Active Screens".
5. Go through each of the entries in the "Active Screens" in the same
6. When you are done with all of the active screens, hit "M" to go back
to the menu. This will save all of your settings. They are NOT saved
until you do that. If you hit ESC at any time to go back to the
previous menu, your changes will be lost.

Anybody have an idea what might be missing?


More information about the mythtv-users mailing list