[mythtv-users] Nuvexport-divx doesn't seem to recognize v_bitrate

Brian Phillips brian.phillips at gmx.net
Mon Nov 19 13:52:03 UTC 2007

After numerous failed attempts at using nuvexport to make myself an avi divx
file with ffmpeg as a userjob, I ran it from the commandline and tested it
on a small file I had using various settings.  I was noticing that no matter
what I set my bitrate to, the file produced always looked like garbage, like
it was VERY low quality.

I ran the following lines and looked at what they produced:

nuvexport --ffmpeg --infile=/storage/recordings/1019_20071117192531.mpg
--path=/storage/ --width=640 --height=480 --mode=divx --deinterlace
--nonoise_reduction --noconfirm --nice=19 --a_bitrate=192 --v_bitrate=1000
nuvexport --ffmpeg --infile=/storage/recordings/1019_20071117192531.mpg
--path=/storage/ --width=640 --height=480 --mode=divx --deinterlace
--nonoise_reduction --noconfirm --nice=19 --a_bitrate=192 --v_bitrate=5000

I then moved /etc/nuvexportrc and /home/mythtv/.nuvexportrc to backup
positions and reran the two commands.

All 4 commands produced practically the same sized file (they were about
1000 bytes off of a 3 MB file).  The compression was about 6x (3 MB from 18
MB).  Yet they all looked the exact same in terms of quality.

I didn't get a drastically different sized file until I set
--v_bitrate=5000000, which gave me a 10 MB file for slightly less than 2x
compression.  The individual frame resolution was good, but the video was

I would love to have my mythtv produce divx files as a userjob, but right
now the divx files produced look like garbage.

Brian Phillips

More information about the mythtv-users mailing list